WordPress.org

Forums

Digress.it
[resolved] digress.it in WordPress 3.0 Multisite with subdirectories (2 posts)

  1. brianglanz
    Member
    Posted 5 years ago #

    Out of the box in this scenario, digress.it navigation menu items 'COMMENTS', 'COMMENTERS', AND 'GENERAL COMMENTS' send you back to the root domain onclick.

    Those links need an href aware of the digress.it site's location. They are lis in the front_menu ul, in the top_bar div, in header.php, lines 101, 103, and 105.

    Without thinking much about it, I saw the apparently equivalent links in the 'CommentBrowser' widget worked and on line 101, changed the href from
    "/?comment-browser=posts"
    to
    "<?php echo $this->wp_path; ?>/?comment-browser=posts"

    but that gives Fatal error: Using $this when not in object context in...

    Instead, to get them working change the relevant bit of line 101 to...

    <a href="<?php echo home_url( '/' ); ?>?comment-browser=posts"

    and equivalents in 103 and 105.

    Thank you @visudo et al. BG

    http://wordpress.org/extend/plugins/digressit/

  2. mrenoch
    Member
    Posted 5 years ago #

    Thanks.

    Paragraph rss feeds were also broken in the same way, and I fixed this by updating

    js/digress.it.js

    window.location.href='/feed/paragraphcomments/'
    to:
    window.location.href=wp_path+'/feed/paragraphcomments/'

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Digress.it
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic