WordPress.org

Forums

WordPress Simple Paypal Shopping Cart
[resolved] Digital Download Email Not Being Sent (6 posts)

  1. SLIS
    Member
    Posted 1 year ago #

    Hello, I'm trying to sell a digital download using your plugin. I followed the video tutorial, but tried doing a test sale and it's not processing.

    When I made a purchase, I get a paypal confirm email, but no email with download link.

    It's also not redirecting to the Thank You page URL that I added in settings when PayPal payment is completed through my site.

    Here's the page with the download: http://petsittingresources.com/pet-sitting-resources-shop/

    The file that is to be purchased is a Word.doc/Zip archive.

    I also enabled IPN settings in PayPal. I didn't see any info in the tutorial as to what the IPN notification url should be, so I assumed it should be the zip file url?

    Any advice would be most helpful. I've been messing with this for several days and just can't figure it out myself.

    Thanks!

    http://wordpress.org/plugins/wordpress-simple-paypal-shopping-cart/

  2. wptipsntricks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, have you enabled debug in the Simple PayPal Shopping Cart settings? I can see that the plugin is submitting the following URL as the return URL:

    http://petsittingresources.com/thank-you/?reset_wp_cart=1

    So if PayPal is not redirecting you after the transaction you should probably check your PayPal account configuration.

    The plugin automatically generates the ipn URL based on your site and submits during checkout. So you don't have to specify any URL (even if you do the plugin will override it). You just need to make sure that IPN option is enabled in your PayPal account.

  3. SLIS
    Member
    Posted 1 year ago #

    Hello,

    I just enabled the debug in the settings, but don't know how to use it. And I'm unsure what else I'm supposed to do as far as PayPal acct configuration is concerned? But they won't let me turn on IPN without inserting a URL. When I leave it blank I get this error:

    You must enter a properly formatted URL into the Notification URL field in order to activate Instant Payment Notification.

  4. wptipsntricks
    Member
    Plugin Author

    Posted 1 year ago #

    In that case please enter your site URL.

  5. SLIS
    Member
    Posted 1 year ago #

    Ok I changed the setting for the url to be the homepage in Paypal settings. Now how do I check my paypal acct configuration so that the thank you page shows up after a purchase?

    Just let me know and then I'll do another test purchase and see if it works.

    Thanks!

  6. mbrsolution
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi SLIS have a look at this tutorial. It will show you two ways you can achieve this depending on your choice.

    Let us know if this helps you.

    Kind regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic