WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Digest e-mails are suddenly empty; {TABLELINKS} not working?

[Resolved] Digest e-mails are suddenly empty; {TABLELINKS} not working?

  • I just bought the HTML version of Subscribe2 after using the standard version successfully for months. An odd thing is happening: My daily digest messages are going out, but the links are missing.

    It’s a very simple template:

    <p>New on VARbuzz:</p>
    
    {TABLELINKS}
    
    <br />
    <p>You received this e-mail because you're a smart person who likes to keep up with what's happening in Virginia real estate.</p>
    <p>Cheers,<br />
    Your friends at VARbuzz</p>
    <br />
    <p><small>Want to unsubscribe? Head to <a href="http://varbuzz.com/buzz-by-mail">VARbuzz.com/buzz-by-mail</a> where you can change your subscription options.</small></p>

    All the text comes through, but there’s just a blank line where there should be the list of posts. Any ideas what’s causing this? Subscribers are getting annoyed by the blank messages!

    http://wordpress.org/extend/plugins/subscribe2/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Update, in case it helps:

    I tried using the {TABLE} code, and I get the same thing — nothing. {TITLETEXT} doesn’t work either (which may be because this is a digest).

    Some shortcodes do work: If I use “{COUNT} new posts” it does say “1 new posts.” And using {POST} gives me the excerpt from my latest post.

    I’m at a loss. Help!

    @andrew,

    That was raised by another user a couple of weeks ago, the thread and solution are here:
    http://wordpress.org/support/topic/links-in-digest?replies=6

    Super, and thanks! I tested it and it worked (yay!), but now it’s asking for my license key again, and it won’t accept it — so I can only send plain text. Any ideas?

    @andrew,

    Ah, that’ll be because there are differences in the affect file between the free and HTML versions.

    I’ll be making an update to the paid code rolling these features and fixes in the near future. You might be better reverting to the paid code version for the time being.

    [confused] But it’s the paid version that didn’t work.

    Did you mean I should switch to the free version for now? And any idea how long before these fixes roll out?

    @andrew,

    The free version will send out populated {TABLELINKS} but it won’t send HTML and will nag you about a license key.

    The HTML version will do the opposite.

    I’m just doing some final testing on the next version. Provided it all goes okay I’ll be hoping to release new code within the next week.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Digest e-mails are suddenly empty; {TABLELINKS} not working?’ is closed to new replies.