WordPress.org

Forums

Twenty Thirteen
[resolved] Different/missing header image on non-index pages (3 posts)

  1. waxpop
    Member
    Posted 1 year ago #

    I recently used cclambie's code on this thread to make my header resizable. I just noticed that now when I click over to any of my pages that's not my main index page (including individual posts), the header doesn't display. It seems to be looking for an image that doesn't exist.

    My main index page: http://www.herfiveyeardiary.com/
    My archives page, for example: http://www.herfiveyeardiary.com/index.php/archives/

    On my index page, the header image used is: http://www.herfiveyeardiary.com/wp-content/uploads/2013/12/arrivingfordinner_header12.jpg

    On any other page, the header image it's looking for is:
    http://www.herfiveyeardiary.com/index.php/archives/wp-content/uploads/2013/12/arrivingfordinner_header12.jpg

    I'm not sure how to set this so that the same header image (and one that actually exists) loads on all pages. Any help would be appreciated!

  2. CrouchingBruin
    Member
    Posted 1 year ago #

    The problem is that your URL has index.php in it (something having to do with your .htaccess file). What you should do, as a quick fix, is to use the full address of your image in the code (http://www.herfiveyeardiary.com/wp-content/uploads/2013/12/arrivingfordinner_header12.jpg) instead of just starting with wp-content/uploads/2013... .

  3. waxpop
    Member
    Posted 1 year ago #

    Thank you! That worked. :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.