Support » Plugin: WP Recipe Maker » Different slugs

  • Resolved NBH707

    (@nbh707)


    We have our site setup so that recipe roundup articles point at individual recipe pages. When we add roundup blocks to a published article, the link is in this format:

    https://genes2teens.com/recipe/mexican-mole/

    However, if we add a recipe roundup block before the article is published, the format of the link is like this:
    https://genes2teens.com/?post_type=wprm_recipe&p=5482

    It stays like that after we publish the article and the links are inaccessible if the user is not logged in.

    Is there a way to use the first type of slug before AND after an article is published? Otherwise, we have to wait until the article is published before we can even add the recipes to it.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Brecht

    (@brechtvds)

    It should automatically use the correct permalink. Maybe some kind of caching problem after publishing?

    Did you try clearing the cache?

    Thread Starter NBH707

    (@nbh707)

    It’s doing it both on the front end and back end. And I see even if the post is already published, it is doing it too. I’m testing a backup of the site from last week on our staging server to see if it looked like that after I created the post but before I published it. There may be some other plugin or code that is causing this.

    Plugin Author Brecht

    (@brechtvds)

    Did you clear any caching plugins though?

    Thread Starter NBH707

    (@nbh707)

    Something happened on July 15. Now I know that is the date you released a new version of the plugin but we also added some custom code that could have affected WPRM data on that day as well.

    However, I have done some testing that should have eliminated any causes but it is still occurring. I have reverted to a July 15 backup and changed the theme to the WP default. I have disabled all the plugins except WPRM (even the premium version I disabled). I also rolled back to version 7.3.0 instead of 7.4.0. And I also reverted the version of WP.

    However, the problem still occurs even with newly created recipes. What I notice is that some recipes have the problem and others do not. We’ve edited a lot of our recipes recently so my feeling is that something is happening when the recipes get resaved.

    Where do the slugs get saved in the database when the recipes are saved/resaved? if I can check there it would help me to narrow down when the problem started to occur and perhaps why.

    Thread Starter NBH707

    (@nbh707)

    Yes I have cleared caches, restored old versions etc. etc.

    I think I have narrowed things down a bit. I’ve identified the first recipe that had the problem and it seems to have affected all recipes saved from that one on. I’m going to check out the exact date in the database for these recipes to see if I can narrow down the possibilites.

    Thread Starter NBH707

    (@nbh707)

    N/A

    • This reply was modified 1 month, 3 weeks ago by NBH707.
    Thread Starter NBH707

    (@nbh707)

    I have narrowed down the problem. It started sometime between June 12 and June 15. All recipes whose original parent article was created after June 12 are having the problem.

    So let’s say we have ABC recipe and ABC article (the good ones) and XYZ recipe and XYZ article (the bad ones).

    If I try to add a roundup item for ABC recipe to either article ABC or XYZ, it works fine. If I try to add a roundup item for XYZ recipe to either article ABC or XYZ, it doesn’t work.

    Were there any updates to the plugin during this period?

    Plugin Author Brecht

    (@brechtvds)

    Can you send me a screenshot of your settings on the WP Recipe Maker > Settings > Post Type & Taxonomies page?

    You could email it to support@bootstrapped.ventures

    Thread Starter NBH707

    (@nbh707)

    Plugin Author Brecht

    (@brechtvds)

    That should be fine. The status of those recipes is “Published” when you check the WP Recipe Maker > Manage page?

    Thread Starter NBH707

    (@nbh707)

    No, but I think you are on to something here.

    We weren’t originally using separate recipe pages or roundup items. Then we went back and added them to all our existing published posts that had multiple recipes in them. I believe all of those have proper links.

    But then we had another article that hadn’t been published yet that we added recipes to and then roundup items BEFORE we published the article. However, I am looking at those recipes on the manage page and they are still showing as drafts.

    All of the other posts where this problem is happening also had the roundup items added when they were drafts.

    I will try creating a new page, publishing it, and then adding the roundup items after and see what happens.

    Thread Starter NBH707

    (@nbh707)

    Actually, a correction, the other posts were not saved as drafts but as scheduled.

    Thread Starter NBH707

    (@nbh707)

    I scheduled a published post that had full recipes in it (not roundups) Then I went back and added a roundup item. to the article (for one of the recipes already in the article) and saved it. All of recipes that are full recipes are showing on the manage page as published except the one I added a roundup item for, which is now showing as scheduled.

    So it seems that somehow when we add a roundup item, it is getting resaved with the wrong status.

    • This reply was modified 1 month, 3 weeks ago by NBH707.
    Plugin Author Brecht

    (@brechtvds)

    The normal usage of WP Recipe Maker is to add every recipe to its own post: https://help.bootstrapped.ventures/article/67-creating-a-recipe

    That will be the parent post of the recipe and the recipe takes over its status: https://help.bootstrapped.ventures/article/279-recipes-and-their-parent-post

    If you want the recipe to just have its own URL on the site without any other post content you have to manually publish that recipe. You can do that through the WP Recipe Maker > Manage page by editing the recipe and changing its status to “Published”. Then the URL will be correct.

    Thread Starter NBH707

    (@nbh707)

    Thanks that worked. You’re the best. I’ll just add publishing the recipes to the process we follow.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.