• Resolved chrisska83

    (@chrisska83)


    Hello all,

    the plugin has worked well so far.
    But now I have discovered that the plugin displays the opening hours slipped forward by one hour.
    Ex. opening time is from 9-14, the plugin displays 8-13.

    In the settings of wordpress the correct time zone is set.
    The opening hours on Google are also correct, because the plugin gets them from Google.
    What else can be the problem?
    Please urgently help!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter chrisska83

    (@chrisska83)

    I changed the time zone with UTC+1 and UTC+2 as a test. There is no visible change. So it is not due to the time zone setting

    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 Please use your actual timezone as the setting (e.g. Europe/Paris).

    It sounds like page caching is delaying the change.

    Thread Starter chrisska83

    (@chrisska83)

    @designextreme

    I have already tried everything.
    I have selected Europe/Berlin as time zone.
    I changed it to Europe/Paris -> no change.

    I also cleared the cache several times. Nothing.

    If I change the times in the backend, they are displayed immediately. So it can not be due to the cache.

    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 There is unlikely to be caching in the Dashboard version, but this can exist in the front-end if you’ve set this run.

    There is a Shortcode parameter to circumvent this, try this:

    [open update="immediate"]

    If you haven’t already, please view the plugin’s FAQ as these issues are covered there.

    Still, I recommend clearing your page caching so your opening hours reflect the current data and time zone.

    You can test for page caching using this:

    [open_text]%now%[/open_text]
    • This reply was modified 1 year, 1 month ago by Design Extreme. Reason: Last part
    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 One other thing that I’d like to add – please check your main opening hours in the Dashboard | We’re Open! and update this after you’ve made any alterations to the time zone. If the data is not refreshed, then it will have the incorrect timestamps for the days and opening hours.

    Thread Starter chrisska83

    (@chrisska83)

    Have now tried everything. Without success.

    Then I got the idea, maybe the wrong time is stored on the server. Because, it has always worked the whole time. It was always the right time.
    I queried the data via phpinfo. And under “Default Timezone” it says CET.
    Can it be maybe because of that?

    Thread Starter chrisska83

    (@chrisska83)

    Sorry translation error. MET is in it

    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 This plugin uses the time zone set in the WordPress Settings. Did you try the test I mentioned earlier? This should show the current time based on your WordPress setup.

    If you haven’t already, please re-save your opening hours when the correct local time zone is set.

    If you continue to have problems, please use the support link to contact me directly.

    Thread Starter chrisska83

    (@chrisska83)

    So this shortcut
    [open_text]%now%[/open_text]
    shows me the wrong time. One hour back.

    Have cleared the cache several times now, but only via a plugin.
    Then looked via FTP, the folder is empty.
    Opening hours completely deleted, saved and then re-entered.

    Then WordPress probably does not pass the time zone correctly.

    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 The web server time zone and time setting would affect this, but it’s rarely incorrect. If its showing the correct opening hours and time zone in the Dashboard, then the same should be conveyed elsewhere in the website.

    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 If the web server time is incorrect, please contact your hosting support.

    You’re also welcome to contact me directly using the support link.

    Thread Starter chrisska83

    (@chrisska83)

    So problem solved.
    It was due to WordPress.

    Under Settings, I selected the following entry for Time Zone -> UTC.

    So no longer Berlin.
    Now the correct time is displayed again.

    Thanks anyway for the time.

    Plugin Author Design Extreme

    (@designextreme)

    @chrisska83 I recommend contacting your hosting support. The geographic time zone should be correct and having UTC means it will be incorrect when summer time ends in October.

    Thread Starter chrisska83

    (@chrisska83)

    I will do that. I’m about to change providers anyway.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Different opening hours’ is closed to new replies.