Support » Plugin: CodeMirror Blocks » Difference rendering between editor and page published

  • Resolved sayannara

    (@sayannara)


    Hello,

    When I edit a page with the default editor, titles, the CodeMirror plugin display text as desired, with the proper CSS. When I publish the page, the rendering change. I do not get what I see.
    I was able to change the color of H1 to green. Obviously styles when editing are not applied to the published page.

    How should I manage this?

    Thank you
    Kind regards,

    Yann

    • This topic was modified 1 year, 1 month ago by sayannara.
    • This topic was modified 1 year, 1 month ago by sayannara.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Vicky Agravat

    (@vickyagravat)

    Hello @sayannara

    Please, can you give more specific detail about what exactly you want?

    Thank you.

    Thread Starter sayannara

    (@sayannara)

    Hi Vicky,

    thank you for your interest.

    Please have a look at this page https://blog.p-difm.com/test/. Do you see the picture at the bottom, that’s what I see, when I editing the page. When the page is published, the rendering change as you can see at the top of the page. Same for the title.
    Looks like a CSS are not the same when I edit and when a page is published.

    My question to be clear, what need I to change to make sure, to have the same styles when editing and publishing?

    Yann

    Plugin Author Vicky Agravat

    (@vickyagravat)

    Hello @sayannara

    The code block rendering on the top of the page. is not CodeMirror block.
    No problem, retain it that code block as it is.

    Please, add CodeMirror block after the image you have provided.
    So, i can observe what is the difference.

    Thank you.

    Thread Starter sayannara

    (@sayannara)

    The code block rendering on the top of the page. is not CodeMirror block.

    Looks like not, but that’s maybe an input, because behind the scene, it is indeed the CodeMirror plugin…

    I have updated the page, hope this time I’m more understandable. Look the title, text and plugin.

    Thank you for your support.

    Yann

    • This reply was modified 1 year, 1 month ago by sayannara.
    Plugin Author Vicky Agravat

    (@vickyagravat)

    Hello @sayannara

    I am trying my best to understand your problem.

    If you think this plugin change your title text.
    So, let me know that, this plugin does not do anything with title text h1 to h6 of your theme.

    It all done by your DIVI theme.

    If your point is that the first ‘Test’ title is render in green color, and others are black, so the first title text is in H1 tag and other title text in H2 tag.
    Your divi theme render H1 in green and other H2 in black.

    If you think, it is plugin fault, please deactivate the plugin and test the same page again.

    Thank you.

    Thread Starter sayannara

    (@sayannara)

    Hi Vicky,

    I am trying my best to understand your problem. Of course, I’m sure you are and I try my best to be clear.

    This plugin does not do anything with title text.
    No, that just an example, although, I need it.

    If your point is that the first ‘Test’ title is render in green color, and others are black, so the first title text is in H1 tag and other title text in H2 tag.
    Your divi theme render H1 in green and other H2 in black.

    Yes I change H1 for green but that is probably not relevant. And yes the first is H1 and the second in H2.

    But
    why when editing, the H1 is not green as you can on the screenshot in my page?
    Why when editing. the text is not the same colour as you can on the screenshot in my page?
    Why when editing, the plugin render differently in comparison with the screenshot in my page?

    I tried to remove the plugin, that does not change anything. For a unknown reason, the styles (css) when editing are not the same when the page is published. I need now to understand why.

    • This reply was modified 1 year, 1 month ago by sayannara.
    Plugin Author Vicky Agravat

    (@vickyagravat)

    Hello @sayannara

    I think, there are some misunderstanding,

    If you have removed the plugin, and still there are no change, it means, there is something wrong in your theme.

    You should ask the same question to DIVI theme forum.

    Thread Starter sayannara

    (@sayannara)

    I recreated a new site, installed another template, and everything works as expected. I’m not sure, maybe the issue was caused by using the DIVI editor and the block default editor on the same website. I lost much time. Probably this issue could have been resolved if I had more experience with themes in WP.

    Thank you
    Yann

    Plugin Author Vicky Agravat

    (@vickyagravat)

    Hello @sayannara

    Thank you for your reply, and mark it as resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Difference rendering between editor and page published’ is closed to new replies.