Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » Didn’t Work On Most Browsers

  • I had high hopes for this plugin but was very disappointed. I could get the pop-ups to appear on my default browser – Opera. But on Chrome, Firefox and Edge, nothing would appear. Yes, I am running the latest version of each of the browsers – before you ask!

    I tried clearing cookies, setting the pop-up to not use cookies, everything! Nothing would make it work.

Viewing 1 replies (of 1 total)
  • Plugin Author danieliser

    (@danieliser)

    @linseyja – Sorry to hear that but it sounds like there is something else at play. If your daily browser is opera, I assume your not logging in when you test on chrome, firefox etc? That would most likely indicate that you have page caching on your server which needs to be flushed. Plugins like W3 Total Cache, WP Super Cache, or even hosting like WP Engine offer this by default.

    IE When logged in you don’t get served cached content, so it works like you expect. When logged out you get a cached copy of the page from before the popup was added. Keep in mind when you save a page it clears its own cache. We can’t do that for popups as they are added to existing pages and based on the variety of conditions we offer that would be impossible to clear caches manually for all of those pages/posts etc.

    Second could be JS errors on the page or a few other things. Did you try our docs or support ticket? Specifically this one has a lot of useful info specifically for diagnosing why a popup isn’t working.

    That said 80% of the time (and we answer a lot of tickets every day), it has little to do with our plugin, its settings or how you set it up, and more to do with server optimization, theme JS errors and the like. So I would implore you to try again and at minimum reassess your review with that in mind since you currently sound like all the issues were the fault of the plugin, which as you can see from our user base couldn’t possibly be the case ;).

    In all likelihood, if you had it working on the browser you were logged in on, it would have worked on the others once the cache was purged. Otherwise try the guides above and let me know.

    Hope that helps. Take care.

Viewing 1 replies (of 1 total)
  • The topic ‘Didn’t Work On Most Browsers’ is closed to new replies.