Support » Plugin: BetterDocs - Best Documentation & Knowledge Base Plugin » Didn’t work for me in the beginning

  • Fresh WordPress install, activated the plugin (no other plugins).
    Quick setup came to the finish page. Can’t click on “Finish” (does nothing).

    I can add categories and docs, but the page that should be automatically generated wasn’t generated by the plugin.
    I switched to manual mode, added a page, added shortcode. Shortcode didn’t produce any results.

    Plugin seems to be broken in the most actual version of WP.

    Update 1: I corrected from 1 star to 2 stars because of the fast reply of the developer to my review. Unfortunately plugin is still not working for me…

    Update 2: Corrected from 2 to 4 stars. I got it working finally thanks to the patience and help of the dev team. They were really engaged in helping me. Great support so far, thank you!
    I had created 2 docs: 1 private and 1 uncategorized.
    Just categorized entries show up in the Knowledge Base.
    The automated generation of the BetterDocs page still doesn’t work. But the shortcode solution is working now…

    • This topic was modified 1 year, 4 months ago by bedengler.
    • This topic was modified 1 year, 4 months ago by bedengler.
    • This topic was modified 1 year, 4 months ago by bedengler.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support rafinkhan

    (@rafinkhan)

    @bedengler,

    Well, ‘Docs’ page is automatically generated by BetterDocs. Besides, the docs you have written, are they ‘Published’? If so, they will appear on your docs page. Can you please confirm both of these?

    If the plugin is broken on latest WordPress version, we wouldn’t have 8,000+ active users. So, please contact support here: support[at]wpdeveloper[dot]net or in the forum and allow us to help. Because this one star rating seems very much unfair.

    Thank you!

    Thread Starter bedengler

    (@bedengler)

    Thanks for your fast reply!
    Of course, if it works, I will correct my review.

    As said, fresh WP install.
    Activated plugin.
    The docs page isn’t generated! After doing the installation wizard there hasn’t been a docs page under pages.
    I have tried another knowledge base plugin now which worked out of the box…

    Thread Starter bedengler

    (@bedengler)

    Deactivating the plugin and reactivating recovers the old settings and lands directly on the “Finish” page of the wizard…
    Even uninstalling didn’t delete the old settings and there’s also no switch within the plugin asking, if the plugin data should be deleted when deactivating the plugin.

    How can I delete the settings and start over from scratch?
    Maybe something happened during the installation process…

    Plugin Support rafinkhan

    (@rafinkhan)

    @bedengler,

    I have just installed BetterDocs Freshly on Latest WordPress setup and Docs page is showing as expected. Here’s what I did: https://d.pr/v/7IyoUE

    Can you please deactivate your other Knowledge Base plugins on your site since they would be conflicting. There’s not much settings in BetterDocs which need to be reverted actually so it should be working. Just make sure you don’t have other plugins activated.

    If you are still facing issue, please show me a screenshot of your BetterDocs Settings. ‘Docs’ page is generated automatically so you don’t have to create it manually.

    Let me know. Thank you!

    Thread Starter bedengler

    (@bedengler)

    I haven’t installed another KB plugin when I installed BetterDocs (I instaled the other one later).
    And I did the same process as you did. The docs page wasn’t created…

    But I have some other plugins. I deactivated all of them and went through the wizard again. But still the same. And the shortcode doesn’t work…

    Here’s my screencast:
    https://www.loom.com/share/5804712e55964f70b3941b7137059a8f

    • This reply was modified 1 year, 4 months ago by bedengler.
    Plugin Support rafinkhan

    (@rafinkhan)

    @bedengler,

    Instead of trying to showcase Documentation on your front page, please create another page on your website and assign that as Documentation page for your website. Besides, once the installation is finished, you don’t need to actually go to the Quick Setup page. You can ignore it.

    Please try it and let me know. Since you are trying to display Docs page on Front Page (which is basically home page and doesn’t have any SLUG), BetterDocs isn’t working (neither the shortcode).

    So, please try it on another page and it should be working fine.

    Thank you!

    Thread Starter bedengler

    (@bedengler)

    I have done that as well before writing the review.
    Here again a video (which was done now, not initially). I created another page and assigned this to BetterDocs…no success…

    https://www.loom.com/share/a6b5174ae38d4eaeb136165a76afa7c0

    Thread Starter bedengler

    (@bedengler)

    I have also tried adding the shortcode “[betterdocs_category_box column=”3″]” to a new page. That doesn’t work either.
    I would like to try to reset the BetterDocs installation. Is there any opportunity to do that?

    Thread Starter bedengler

    (@bedengler)

    If you like, I can give you access to the WP installation. Just tell me an e-mail address where to send a login to…

    • This reply was modified 1 year, 4 months ago by bedengler.
    Plugin Support rafinkhan

    (@rafinkhan)

    @bedengler,

    Please try the ‘Built in Documentation’ option as in the screenshot:
    https://d.pr/i/zMAYSs

    Did you create any doc by the way? From the screen record, I couldn’t see any. Can you please make sure you have created a few docs and have assigned them inside ‘Categories’ too?

    Anyways, please come to support and we will resolve this for you. Mail us here: support[at]wpdeveloper[dot]net

    Thank you!

    Thread Starter bedengler

    (@bedengler)

    Ok, finally I got it working with the shortcode version. One article was uncategorized and the other private. That seems to be the reason why there showed up nothing.

    Maybe you can add articles that are uncategorized in a aut-generated category or is it by intention that uncategorized docs are hidden?
    Or show the user a hint if he has articles, but no one of them is categorized!?

    The automated generation still doesn’t work for me.

    Please see here:
    https://www.loom.com/share/9121eacdbea648979979500980f1408c

    I have set up a user for you and you should have been sent the credentials into your inbox.

    • This reply was modified 1 year, 4 months ago by bedengler.
    Plugin Support rafinkhan

    (@rafinkhan)

    @bedengler,

    It was a permalink issue. I have changed it to post name and everything works fine. Check your doc page now: https://wiki.katching.net/docs/

    It would be great if you change your rating now since your original issue is fixed. I would really appreciate it.

    For further queries, please contact support.

    Thank you

    Plugin Support rafinkhan

    (@rafinkhan)

    @bedengler,

    Default BetterDocs Doc page works now. Please check. Thanks

    Thread Starter bedengler

    (@bedengler)

    Awesome, great support, thank you!
    I have corrected it to 4 stars now.
    I also didn’t find in your documentation anything covering this topic. So I think (compared to the other solution), the setup could be improved.

    Nevertheless: keep up your good work!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Didn’t work for me in the beginning’ is closed to new replies.