Support » Plugin: CAOS | Host Google Analytics Locally » did not work on some devices in chrome browser

  • Resolved Gabriel Marmitt

    (@gabriel-marmitt)


    Hi, DaanvandenBergh.

    I’ve used your plugin to do the suggested optimization on the PageSpeed Insights page for Leverage Browser Cache.

    I ran tests on various browsers for android, looking at the result on the Google Analytics page, using the tool to see in real time, and I saw that it did not work in chrome on 2 phones, I did a third test still on chrome on a third cell phone and it worked . In the other browsers for android I did the test worked, also worked in computer browsers.

    To take the test I took the footer code and left only the plugin enabled.

    I had to re-enable the analytics code on the footer to work again.

    Thank you for your attention and I look forward to a return.

    Sincerely, Gabriel Marmitt

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I’m sorry, but I’m not sure I completely understand you. Could you send me a screenshot of your used configuration?

    You say the tests failed on 2 phones? Were these old phones? Which version of Chrome were you using on these phones? Were any plugins (such as adblockers) installed?

    What happened when you chose to place the tracking code in the header? It’s common knowledge that placing Analytics-code in the footer can lead to unexpected results (it’s a *use at your own risk* option in CAOS, that’s why header is the default option).

    In short, I’m going to need more information to see if I can help you here…

    In the CAOS configuration I only put the Google Analytics Tracking ID, and the rest of the configuration is in the default. I also removed the ID code that was in the footer of my theme, to be able to test the CAOS, leaving the Tracking ID connected only in the CAOS plugin.

    The failed tests were on 2 phones, not old, but from lower brands, branded Multilaser, using chrome version 65.0.3325.109. I upgraded the chrome to the latest version and it did not work.

    Another phone I used was a motorola, that phone worked.

    I do not have any plugins to block ads.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    I’m sorry, but I have no explanation for this.

    You could try installing Monster Insights’ Google Analytics for WordPress and run CAOS in compatibility mode to use the locally hosted file generated by CAOS.

    I hope that works.

    It’s weird, because there’s no difference between the tracking code used by CAOS and Google’s own tracking code. It did work on the phone with the regular code?

    Yes, it worked on 2 phones by whistling the normal code. In any browser, I’ve installed a few more browsers to test. I only found this error in Crhome on 2 devices, as I said before it worked in Chrome on a third device.

    I figured out what was wrong, I was logged in as an admin, and so I was not showing up on my visit to analytics.

    I used the CAOS with the monster, the 2 together work well, but I preferred to use only the CAOS, because I had a better result in pingdom and Insights.

    Thank you for your support and attention. Congratulations on the excellent development, I wish you success.

    Sincerely, Gabriel Marmitt

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘did not work on some devices in chrome browser’ is closed to new replies.