Support » Plugin: Swift Performance Lite » Did not cache for user

  • Hi,

    Can i know how to cache for login user?
    I use google “view page source” to check but i can’t see the page are cached, even i try to logout from my account, the page are still serve page without cache.
    If the visitor visit for the 1st time the page are cached, after login or logout the page are uncache, can i know how to solve it?
    Please advice.

    Thank you.
    Keat

    • This topic was modified 1 year, 10 months ago by keat18.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Scottie S

    (@doit686868)

    You can set the caching for logged in users. Go to Settings > caching > general and check the box “Enable Caching for logged in users”.
    Please note: all logged in users have a separate cache for every page. It can increase the total cache size, depending on the count of your users and number of pages.

    Hi, i’m already set “Enable Caching for logged in users”.
    but i can’t see the >>>
    <!–Cached with Swift Performance Lite–>
    at view page source for login user & it’s load slowly without caching.

    You can try login & check the page are cached?

    Looking forward for your reply soon.

    Thanks

    • This reply was modified 1 year, 10 months ago by keat18.
    Plugin Author swte

    (@swte)

    Hi,

    Is the Optimize Prebuild Only option enabled? If yes, please try to disable it, and set Optimize in background instead.

    Plugin Author swte

    (@swte)

    Also please enable Shared Logged in Cache, I think you need that option instead creating separate cache for every user.

    If you enable Shared Logged in Cache you can still use (and it is recommended to use) Optimize Prebuild Only

    Hi @swte,

    I’m already enable Shared Logged in Cache & Optimize Prebuild Only.
    After user login, there are only certain page are cached like home page, contact us, shop page, but it still show “Login/rRegister” button to the user even they login.
    See attached = https://imgur.com/1mh6IWq
    At the same time, some products page under brand, my account & checkout page are did not cache & it will show “My Account” button.
    See attached = https://imgur.com/oGP8BWK

    I think this will looks confuse to our user when the login to our website.

    Do u have any suggestion to solve this issue.

    Looking forward for you solution.

    Thank you.
    Keat

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Did not cache for user’ is closed to new replies.