Support » Plugin: Swift Performance Lite » Did I miss something?

  • Resolved badscooter1980

    (@badscooter1980)



    So, I installed and setup using the wizard, but nothing has changed?

    I have ticked the minify html/css boxes etc, but nothing? Nothing has been minified.

    The site is also getting the exact same score in GT Metrix than before, actually slightly lower due to the extra http request.

    Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Fred

    (@fredawd)

    Probably your pages are not cached at all. Check the warm-up table if (all) pages are cahched. It could due to another cache layer which is active?

    Please provide an URL so we might find out what the issue is.

    Hi Fred,

    OK, so I did briefly have this working this morning. I had some left over settings when I removed Comet Cache, so I think that’s what caused the issue.

    No, it has stopped working again.

    I changed an image on my homepage, updated it and now the site isn’t caching, it’s lost the minified HTML/CSS etc.

    The URL is https://www.plantsforeurope.com/

    Any ideas?

    OK, it’s back again. This is weird.

    Each time I update a page in the backend, the frontend (in a different browser/not logged in) reverts back to an uncached/unminified version.

    I ‘kind of’ understand why, but what is your take on this? Is there a time delay setting somewhere?

    Plugin Contributor Fred

    (@fredawd)

    If I look to your website, it´s not cached at all. There must be some other cachelayer active or code left.

    Did you enable Prebuild Cache Automatically?

    Hi,

    Yes, everything is set to exactly how it should be.

    It appears just fine now, but is it normal behaviour for the page/site to uncache itself when you update a post/page?

    It seems that when this happens I have to manually clear to the cache and then ‘reset warmup table’. Is this normal?

    Installed on another site, which has never had caching on before, and having a similar issue where it just isn’t caching the page (https://www.aeromobile.net/)

    All settings are correct, I’ve clicked ‘start prebuild cahce’, I’ve clicked ‘reset warmup table’, but nothing. Is there a delay somewhere that I am not aware of? Is this an entirely manual process?

    Any ideas?

    Plugin Contributor Fred

    (@fredawd)

    it is certainly not good. Cache should be (re)build automatically. Can you tell us more about the server environment?

    Any other cache layer active? Are you using CDN or Cloudflare?

    Hi,

    No CDN and no other cache plugin installed, or ever has been.

    There seems to be a couple of issues.

    1) I have to manually trigger the cache run.
    2) Updating any page/post seems to force the entire sites cache to clear, meaning every page/post must be recached.
    3) Now, I have just logged back in to the site and all previously cached pages have now been uncached.

    Plugin Contributor Fred

    (@fredawd)

    Thanks for the input.

    The cache will be cleared when:
    – the post was modified
    – post was deleted/moved to trash
    – woocommerce product stock/any props was changed
    – post status was changed (eg scheduled post)
    – any plugin was activated/deactivated
    – any plugin was updated
    – theme was updated
    – WordPress core was updated
    – after switch theme
    – any change in menu
    – any change in customizer
    – if comment was send/approved

    May I ask if you have any redirect plugin installed, such as Really Simple SSL or similar?

    Hi,

    No redirect plugins as such, but the hosting company handle the HTTPS requests; “We do redirect your website this is done by our load balancers not via any code. The load balancer deals with an HTTP request and will automatically force it to use HTTPS”

    So, the ENTIRE cache for the website (every post/page/post type) is cleared when any post is updated? That seems a little overkill.

    To clarify, if I update a block of text on my homepage, then every other page/post cache is also cleared, not just the page I updated?

    Plugin Contributor Fred

    (@fredawd)

    No, when you update a page or post, only that one is cleared and rebuild. I just wanted to list the triggers for cache. Sorry for the confusion.

    Without access to your website and exactly see the configuration you set, It`´s hard to say what exactly causes your issue.

    Is wp-cron perhaps disabled?

    Plugin Contributor Fred

    (@fredawd)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to re-open this topic. Please read our faq before open a new request.

    Thanks for understanding!

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.