Support » Plugin: CF7 Google Sheets Connector » Dev broke the app to force $29/year purchases

  • Very useful plugin. When a form is entered, the spreadsheet updates are more reliable than the e-mails from CF7. Dev intentionally broke the app in December 2018 for a while with no warning in an attempt to get people to upgrade to the Pro version, which was disappointing. Looks like it’s working again (January 2019) with no restrictions. Hopefully it continues working with no further breaks.

    • This topic was modified 4 months, 1 week ago by  Novac.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Abdullah WesternDeal

    (@westerndeal)

    Nothing is broken, Everything seems to be working perfectly as it was before.
    You should as in support first before submitting here, as logic had been changed in FREE version. Where as you can still use constantly as it was before.
    Still we are here to help you please raise the tickets from the link given on description page.
    Thanks
    s

    Everything seems to be working perfectly as it was before.

    This is simply not true. When you “change the logic” on a plugin in an update without warning and that logic removes features that people have been using for years, that is not considered to be working fine — at least it’s not working fine from the user’s perspective. From the developer’s perspective, I guess you could consider it as “working fine” when you intentionally remove the features and ask for payment because that’s what you wanted to happen. I would be much happier if the plugin broke due to a mistake or bug, but clearly this was intentional.

    You should as in support first before submitting here

    I don’t review plugins lightly. I posted in support and received an unsatisfactory answer back and saw the responses that others were getting on the same issue. You should recognize my username from the support thread you replied to titled “Connection Limit Reached and know that I did not post here without attempting to receive support first.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    *Reads topic at https://wordpress.org/support/topic/connection-limit-reached/ *

    Wait. What?

    It will work randomly in Free Version

    @westerndeal You need to explain that here. Preferably before I look at the code for your plugin.

    How exactly did you implement that random limitation?

    Plugin Author Abdullah WesternDeal

    (@westerndeal)

    Hi @jdembowski,

    We did added a limitation in version 2.2 but after getting reviews we realized that plugin is not working as per the above change. We had fixed that in version 2.3 with limit of forms to connect 2 Contact Forms with Google Sheet.

    Due to many users issues we have now increased the limitation of first 5 Contact Forms to be connected with the Google Sheet.

    Now we have also mentioned in change log and plugin is working as it was before, comparatively the only change is the limitations of the contact forms.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    This is a very serious question and how you answer it is very critical.

    Due to many users issues we have now increased the limitation

    Are you introducing that in your plugin code? I honestly do not want to look but if I have to I will make the time.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    And before anyone thinks of prevaricating, I am asking you if I edit your plugin code can I remove the limitation?

    Remember, I promise to look at the code. I’d rather have your honest reply first.

    Plugin Author Abdullah WesternDeal

    (@westerndeal)

    Yes already introducing the code of limitation within the plugin code only.
    You can go ahead and review the code for sure, but WHY to remove the limitation from code?
    Why should i allow to remove limits to connect google sheets? can you please explain?
    There is nothing serious with the code, if you will review the code you will get an idea.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Because introducing an artificial limitation makes your plug-in trialware and that’s not permitted in the WordPress plugin repository.

    If your plugin was an interface to your service then that may be permitted If the limit was not in the code but in your service.

    That does not appear to be the case here.

    Plugin Author Abdullah WesternDeal

    (@westerndeal)

    @novac
    Nothing is broken, have you tested the new release of plugin,
    let me know if you still having any issues.

    Thanks
    Abdullah

    Yes, a couple weeks ago (after @jdembowski ‘s comment above) the restriction was removed from the plugin. Thanks for that. But now I’m afraid to update it again for fear that it will be broken again. I guess I have to live with the “1 update” notification on my WP Dashboard because I can’t trust the updates to this plugin any more.

    Plugin Author Abdullah WesternDeal

    (@westerndeal)

    lol,
    I can understand, but now i am having a fear to give updates and launch new version, as suddenly plugin will be deactivated from repository if users claims like this.
    Anyways, feel free to update and let me know if you have any issues.
    We will add more features for FREE users too !

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this review.