The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Widget Settings Importer/Exporter
[resolved] Detection and message for PHP 5.2 users? (2 posts)

  1. Steven Gliebe
    Posted 3 years ago #

    I understand version 1.1 requires PHP 5.3, otherwise users get "Parse error: syntax error, unexpected T_FUNCTION". It might be a smoother experience for users if some version detection is used in order to let the plugin install and then show the user a message asking them to upgrade PHP or downgrade the plugin in order to use it.

    This plugin is very useful and I recommend it to all my theme users but since the 1.1 release I get a lot of questions about this error because they are unsure what the problem is.

    Thank you again for this handy tool.


  2. Kevin Langley
    Plugin Author

    Posted 3 years ago #

    I can definitely see a value in adding that as a message with a direction to either upgrade or download version 1.0.

    I'll include that in the next version of the plugin.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Widget Settings Importer/Exporter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.