WordPress.org

Forums

JM Twitter Cards
[resolved] Descriptions Missing (12 posts)

  1. amiyuy
    Member
    Posted 10 months ago #

    I am having the same problem as another poster, the Card Validator says that my pages are missing twitter:description. Which is true, because when I check the page source, it is missing.

    Yesterday's post I manually added the meta tag code to the post content and it started working: http://amiyuy.com/wow/2014/06/alpha-impressions-as-of-june-19-2014/
    Today's post is missing it as well: http://amiyuy.com/wow/2014/06/wod-alpha-interface-maps-as-of-june-20-2014/

    The only plugin that I have that could even remotely be interfering is Jetpack, and that's simply because I don't know everything it's doing. I do not have any SEO plugins.

    https://wordpress.org/plugins/jm-twitter-cards/

  2. tweetpressfr
    Member
    Plugin Author

    Posted 10 months ago #

    Humm this issue is difficult to resolve. Jetpack's developer told me their Twitter cards just leave when my plugin is active so I doubt this is due to Jetpack.

    There's some glitch. I have to check this. The more information you give the more I can solve the issue. What is your configuration. Just send me a list of your active theme and plugins by mail contact[at]tweetpress.fr

  3. amiyuy
    Member
    Posted 10 months ago #

    Sent. Hopefully that helps.

  4. cachestream
    Member
    Posted 9 months ago #

    Not sure if your situation same as mine, but I have found if you have an image at the top of your post, the Twitter description is not populated.

    I moved my image down a few lines on a post, refreshed, and the description works - grabs the first couple lines of my post as the description.

    Having an issue though, grabbing the description from Yoast SEO.

  5. tweetpressfr
    Member
    Plugin Author

    Posted 9 months ago #

    @cachestream : do not understand why you get that. Works here : link

  6. amiyuy
    Member
    Posted 9 months ago #

    cachestream is right, that is the deciding factor for me too.

    I do not see a description in my preview at all with the picture at top: Screenshot
    I do when I remove the image: Screenshot

  7. stefsull
    Member
    Posted 7 months ago #

    Yes, this is what happens to me too. If I have an image as the very first part of my post, the description field just doesn't show up in the Twitter cards.

    We also have some custom code we add (just a couple divs with classes) that hold an image and start some of our posts. This also makes the description fail. It only works if the post starts with words only.

  8. tweetpressfr
    Member
    Plugin Author

    Posted 6 months ago #

    I'm on this ! Hopefully I'll find th time to fix this for the next update.

  9. bobwadd
    Member
    Posted 6 months ago #

    Same issue here.

    All works fine if there is text before the image. No description if image is first.

  10. tweetpressfr
    Member
    Plugin Author

    Posted 6 months ago #

    fixed in 5.3.6

  11. Rugged Fellow's Guide
    Member
    Posted 6 months ago #

    My site used to work fine, now I've noticed the description is missing as well and I also use an image in the first part of my post (which is the same as my featured image).

    When I check the Twitter Card validator, I get:
    ERROR: Required meta tag missing (twitter:description)

    I use Yoast SEO also but the social plugins are turned off.
    All plugins are up to date.

    The site I'm having trouble with is http://www.ruggedfellowsguide.com

  12. degmezivindirik
    Member
    Posted 5 months ago #

    Hello,

    I installed the plugin yesterday.
    The same issue.
    When the page has no words, then

    ERROR: Required meta tag missing (twitter:description)

    Doesn't your plugin have a field for description or get the description from "All in one SEO"?

    Best,

Reply

You must log in to post.

About this Plugin

  • JM Twitter Cards
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic