Support » Plugin: CC Child Pages » Depth not working with images

  • Resolved AdventureRidingNZ

    (@adventureridingnz)


    Hiya

    The instructions indicate you’ve updated the plugin so that “The depth parameter can now also be used with the shortcode when list is not set or is is set to “false”.”
    but it doesn’t seem to be working.

    I’m using the below and everything works except the depth, I only get the first layer returned.

    [child_pages id=”33714″ thumbs=”true” link_thumbs=”true” link_titles=”true” post_status=”publish” hide_excerpt=”true” hide_more=”true” depth=”2″ skin=”blue”]

    I’ve tried setting featured images on the lower level pages, setting subpage_title, setting list=”false” but nothing beyond the 1st level is generated is images are on.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter AdventureRidingNZ

    (@adventureridingnz)

    Even if I remove the thumbs=”true” and link_thumbs=”true” depth only seems to be working if list=”true”

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    Hi @adventureridingnz

    The depth parameter actually adds the sub-pages as a list, rather than a fully formatted child-page with images, etc.. The reason for this is that it would be very difficult to accommodate lots of sub-pages (and their own sub-pages) while still showing the hierarchy of the pages.

    Imagine the following scenario:

    • The cols parameter is set to 3
    • The depth parameter is also set to 3
    • Each page or child page to be displayed has at least 3 child pages

    The first set of pages would be displayed in 3 columns, but adding the next set of child pages to each box effectively produces 9 columns of sub-pages … going down another level gives 27 columns, and so on.

    This can get pretty unwieldy, and so the compromise was to show the sub-pages of the child-pages as a list.

    This was not a feature that I actually wanted to add, but it was requested by someone as a particular requirement … if I get time i the future, I will look at a better way to do this.

    However, I am a bit surprised by your last reply and will test this out for myself.

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    Hi … I believe that I may have misunderstood the problem.

    As promised, I have been testing the plugin to try and reproduce the error – but was failing to do so.

    However, when I copied your example from your earlier post … it failed.

    I think the problem may be that not all of the quotes in your example are standard double quotes … so the passing of parameters is not working as expected.

    I manually replaced the double quotes, and everything worked as expected.

    If I am getting this wrong and the quotes thing is just a display thing on this forum, please let me know …

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    Your code:

    [child_pages id=”33714″ thumbs=”true” link_thumbs=”true” link_titles=”true” post_status=”publish” hide_excerpt=”true” hide_more=”true” depth=”2″ skin=”blue”]

    My code:

    [child_pages id="33714" thumbs="true" link_thumbs="true" link_titles="true" post_status="publish" hide_excerpt="true" hide_more="true" depth="2" skin="blue"]

    Plugin Author caterhamcomputing

    (@caterhamcomputing)

    I haven’t heard back, so I am assuming this issue is now resolved. If you still have problems, please do not hesitate to get in touch.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Depth not working with images’ is closed to new replies.