Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Deprecation Warning

  • Resolved Peter Wooster

    (@pkwooster)


    Nextgen version 2.1.49 and Yoast SEO version 3.4.1 causes a deprecation warning for line 118 of /wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/module.attach_to_post.php

    The warning is wpseo_pre_analysis_post_content filter/action is deprecated since version WPSEO 3.0! Use javascript instead.

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author photocrati

    (@photocrati)

    @pkwooster – We are aware of this message when WP_DEBUG is set to true; and, it also appears Yoast SEO continues to use this hook themselves.

    Thanks for bringing it to our attention again.

    – Cais.

    Thread Starter Peter Wooster

    (@pkwooster)

    Thanks Cais, I thought you might know about it, but wasn’t sure as it’s a relatively new Yoast deprecation. I run with debug=true on all my test and QA systems and these messages break some other plugins like wp-migrate-db which produces corrupted backups when a message is written at the top of the admin.
    /peter

    Plugin Author photocrati

    (@photocrati)

    @pkwooster – Thanks, again! I have written this up for our developers to review further but unfortunately I do not have a time line on when that will be at the moment.

    Thanks, also, for the extra details about the secondary issue with the WP Migrate DB plugin.

    – Cais.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Deprecation Warning’ is closed to new replies.