Support » Plugin: WooCommerce PPOM » Deprecated WooCommerce hook causes errors

  • Resolved Neejoh

    (@neejoh)


    In the Apache errors log there is a really big list of errors that say that the plugin uses a deprecated hook:

    [Tue Apr 17 11:28:26.286479 2018] [:error] [pid 19456] [client 111.222.333.444:port] woocommerce_add_order_item_meta is deprecated since version 3.0.0! Use woocommerce_new_order_item instead., referer: https://domainname.nl/checkout/

    This is caused in:

    plugins/woocommerce-product-addon/inc/functions.php:73:		   woocommerce_add_order_item_meta($item_id, $key, $val);
    plugins/woocommerce-product-addon/classes/plugin.class.php:105:		add_action ( 'woocommerce_add_order_item_meta', 'ppom_woocommerce_order_item_meta', 10, 3);

    Can this please be fixed?

Viewing 1 replies (of 1 total)
  • Plugin Author N-Media

    (@nmedia)

    Hi Neejoh,

    we have fixed this issue in version 11.6 it will be released soon.

    BR,
    Najeeb

Viewing 1 replies (of 1 total)
  • The topic ‘Deprecated WooCommerce hook causes errors’ is closed to new replies.