Support » Plugin: Advanced Custom Fields: Extended » Deprecated notices during activation

  • Resolved Enchiridion

    (@enchiridion)


    Hi,
    I recently upgraded to PHP8.0 and now when the plugin is activated it generates several PHP Deprecated notices.

    WP 5.6
    PHP 8.0.1
    Advanced Custom Fields PRO 5.9.4
    Advanced Custom Fields: Extended 0.8.7.6

    [16-Jan-2021 00:26:40 UTC] PHP Deprecated:  Required parameter $field follows optional parameter $post_id in /var/www/site/public/content/plugins/acf-extended/includes/modules/form/admin.php on line 1354
    [16-Jan-2021 00:26:40 UTC] PHP Stack trace:
    [16-Jan-2021 00:26:40 UTC] PHP   1. {main}() /var/www/site/public/wp/wp-admin/plugins.php:0
    [16-Jan-2021 00:26:40 UTC] PHP   2. require_once() /var/www/site/public/wp/wp-admin/plugins.php:10
    [16-Jan-2021 00:26:40 UTC] PHP   3. require_once() /var/www/site/public/wp/wp-admin/admin.php:34
    [16-Jan-2021 00:26:40 UTC] PHP   4. require_once() /var/www/site/public/wp/wp-load.php:42
    [16-Jan-2021 00:26:40 UTC] PHP   5. require_once() /var/www/site/public/wp-config.php:191
    [16-Jan-2021 00:26:40 UTC] PHP   6. do_action($tag = 'init') /var/www/site/public/wp/wp-settings.php:557
    [16-Jan-2021 00:26:40 UTC] PHP   7. WP_Hook->do_action($args = [0 => '']) /var/www/site/public/wp/wp-includes/plugin.php:484
    [16-Jan-2021 00:26:40 UTC] PHP   8. WP_Hook->apply_filters($value = '', $args = [0 => '']) /var/www/site/public/wp/wp-includes/class-wp-hook.php:311
    [16-Jan-2021 00:26:40 UTC] PHP   9. ACF->init('') /var/www/site/public/wp/wp-includes/class-wp-hook.php:287
    [16-Jan-2021 00:26:40 UTC] PHP  10. do_action($tag = 'acf/init', ...$arg = variadic(5)) /var/www/site/public/content/plugins/advanced-custom-fields-pro/acf.php:326
    [16-Jan-2021 00:26:40 UTC] PHP  11. WP_Hook->do_action($args = [0 => 5]) /var/www/site/public/wp/wp-includes/plugin.php:484
    [16-Jan-2021 00:26:40 UTC] PHP  12. WP_Hook->apply_filters($value = '', $args = [0 => 5]) /var/www/site/public/wp/wp-includes/class-wp-hook.php:311
    [16-Jan-2021 00:26:40 UTC] PHP  13. ACFE->includes(5) /var/www/site/public/wp/wp-includes/class-wp-hook.php:287
    [16-Jan-2021 00:26:40 UTC] PHP  14. acfe_include($filename = 'includes/modules/dynamic-form.php') /var/www/site/public/content/plugins/acf-extended/acf-extended.php:199
    [16-Jan-2021 00:26:40 UTC] PHP  15. include_once() /var/www/site/public/content/plugins/acf-extended/init.php:17
    [16-Jan-2021 00:26:40 UTC] PHP  16. acfe_include($filename = 'includes/modules/form/admin.php') /var/www/site/public/content/plugins/acf-extended/includes/modules/dynamic-form.php:12

    Here are the other notices without the full trace.

    [16-Jan-2021 00:26:40 UTC] PHP Deprecated:  Required parameter $field follows optional parameter $post_id in /var/www/site/public/content/plugins/acf-extended/includes/modules/form/admin.php on line 2922
    [16-Jan-2021 00:26:40 UTC] PHP Deprecated:  Required parameter $login follows optional parameter $type in /var/www/site/public/content/plugins/acf-extended/includes/modules/form/actions/user.php on line 364
    [16-Jan-2021 00:26:40 UTC] PHP Deprecated:  Required parameter $pass follows optional parameter $type in /var/www/site/public/content/plugins/acf-extended/includes/modules/form/actions/user.php on line 364
Viewing 1 replies (of 1 total)
  • Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Thanks for the feedback! The plugin hasn’t been tested yet with PHP 8. I took a look at the notices, and they’re not alarming, the plugin should work correctly.

    I’ll add a compatibility patch for PHP 8 in the next update!

    Have a nice day!

    Regards.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.