Support » Plugin: Display Eventbrite Events in WordPress ( Widget ) » Deprecated message – Parse error (PHP 7.4)

  • Resolved Carambola

    (@tsjemo)


    Hello,

    Switching from PHP 7.3 to 7.4 returns these errors (switching back to 7.3 and it disappears). Any advice?

    Deprecated: Array and string offset access syntax with curly braces is deprecated in /data/sites/web/mannekenbizzbe/www/wp-content/plugins/widget-for-eventbrite-api/includes/class-eventbrite-manager.php on line 231

    Parse error: syntax error, unexpected ‘}’, expecting end of file in /data/sites/web/mannekenbizzbe/www/wp-content/themes/manneken-bizz/widget-for-eventbrite-api/widget.php on line 151

    Line 151 is the line with “else”…

    
        }
        ?></ul>
    
    	<?php 
    } else {
        ?>
        <p class='not-found'><?php 
        _e( 'No Events Found', 'widget-for-eventbrite-api' );
        ?></p>
    	<?php 
    }
    
    ?>
    </div><!-- Generated by http://wordpress.org/plugins/widget-for-eventbrite-api/ -->
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Fullworks

    (@fullworks)

    Thanks for advising in the PHP 7.4 issue I will investigate.

    Plugin Author Fullworks

    (@fullworks)

    I have fixed the PHP 7.4 warning in release 2.8.11

    Your other issue is in your own code as that is in your theme www/wp-content/themes/manneken-bizz/widget-for-eventbrite-api/widget.php

    so your developer has overridden the widget template

    If you want me to have a look, you will need to post the whole code of www/wp-content/themes/manneken-bizz/widget-for-eventbrite-api/widget.php to a gisthub or similar

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Deprecated message – Parse error (PHP 7.4)’ is closed to new replies.