Support » Plugin: a3 Lazy Load » Deprecated Message by jQuery Migrate Helper

  • Resolved mitfi

    (@mitfi)


    Dear support team,

    With „jQuery Migrate Helper“, I receive the following message:

    /wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js: AJAX events should be attached to document: ajaxComplete

    Do you plan for a change in your code to cover this?

    Best regards

    Michael

    • This topic was modified 6 months ago by mitfi.
Viewing 12 replies - 1 through 12 (of 12 total)
  • I have the same question.

    Thank you,
    Danielle H.

    I have the same problem. Do you have an update of the plugin please?

    Thanks!

    The problem still exists, will this be corrected any time soon

    Same problem.

    I really like A3 Lazy Load, and I want to keep using it, but if it is not fixed it looks like its days are numbered!

    Plugin Author Steve Truman

    (@a3rev)

    Hi @mitfi, @pamahfoundation, @mijia99eggers, @pmsoft85, @kapman

    Version 2.4.2 is out with Compatibility with WP 5.6 – It contains the fix for this issue.

    Here is the changelog

    2.4.2 – 2020/12/08

    * This maintenance release has tweaks and bug fixes for compatibility with WordPress major version 5.6, PHP 7.4.8 and WooCommerce 4.7.1
    * Tweak – Test and Tweak for compatibility with PHP 7.4.8
    * Tweak – Test for compatibility with WordPress 5.6
    * Tweak – Test for compatibility with WooCommerce 4.7.1
    * Fix – Attached ajaxComplete to document instead of window
    * Fix – Replace old isFunction by typeof check function

    Steve

    Thread Starter mitfi

    (@mitfi)

    Hi @a3rev,

    Good job!

    Thank you very much!

    Best regards

    Michael

    KAPman

    (@kapman)

    Hi Steve,

    Brilliant! Thanks very much.

    Cheers

    Keith

    colinm2020

    (@colinm2020)

    I have 2.4.2 loaded and JQuery Migrate is showing an AJAX error
    AJAX events should be attached to document: ajaxComplete
    plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js

    Is this work in progress or something else on my site ?

    regards
    colin

    Thread Starter mitfi

    (@mitfi)

    Dear @colinm2020,

    I just checked and I can re-conform that such deprecated messages disappeared – at least in my environment – after updating to 2.4.2.

    Best regards

    Michael

    KAPman

    (@kapman)

    I agree with Michael – the deprecated message disappeared after the update.

    Cheers

    Keith

    colinm2020

    (@colinm2020)

    Thanks Michael — yes i can confirm the update has removed the messages.
    Colin

    Hi Michael

    I am sorry to report the error message is again in the log. it took 4 days to be seen again.

    2020-12-14 19:32:08 AJAX events should be attached to document: ajaxComplete Plugin: a3 Lazy Load

    wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js

    I have other messages from a theme Polestar.

    Enable JQuery Migrate Helper version 1.3.0
    I am set to Legacy 1.12.4-wp and show deprecation notices on each admin page as they happen.

    a3 Lazy Load version 2.4.2

    regards
    colin

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.