Support » Plugin: Woo Image SEO » Deprecated jQuery code

  • Resolved titsmaker

    (@titsmaker)


    As you know WordPress devs finally decided to upgrade to current JQuery version in 2020. Now WP core uses latest Jquery + JQuery Migrate, but in the future (in WP 5.7 actually – https://core.trac.wordpress.org/ticket/51812) JQuery Migrate will be gone and all deprecations will turn into errors.
    Your plugin has following deprecated jQuery events in settings.js:

    jQuery.fn.submit()
    jQuery.fn.click()

    You can see more detailed info about this deprication here – https://github.com/jquery/jquery/issues/3214
    Can you please update the code?

    • This topic was modified 1 year, 10 months ago by titsmaker.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author emandiev

    (@emandiev)

    Thank you for the feedback!

    Next week you can expect an update that fixes the jQuery issues and improves compatibility with WordPress 5.7

    I will close this topic once the plugin update is live.

    Plugin Author emandiev

    (@emandiev)

    Hello friend!

    I just released version 1.2.2

    It contains the jQuery fixes you proposed.

    Good luck with the sales!

    Thread Starter titsmaker

    (@titsmaker)

    Thanks for resolving this!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Deprecated jQuery code’ is closed to new replies.