Support » Plugin: Reaction Buttons » Deprecated has_cap usage

  • Resolved flufftron

    (@flufftron)


    Hi there, I’m using this plugin on a server running php 7 and get errors pointing me to this line in reaction_buttons.php:

    add_options_page('Reaction buttons', 'Reaction Buttons', 8, 'reaction_buttons', 'reaction_buttons_submenu');

    Would seem this 8 is from has_cap, instead of using the roles and capabilities system. I fixed it by changing to:

    add_options_page('Reaction buttons', 'Reaction Buttons', 'administrator', 'reaction_buttons', 'reaction_buttons_submenu');

    ..just in case anyone else runs into this or plugin author wants to edit. Thanks!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Deprecated has_cap usage’ is closed to new replies.