Support » Plugin: Add From Server » Deprecated function and characters not properly escaped

  • Resolved dajense

    (@dajense)


    This warning is generated when activating the plugin. Somehow it also manages to brake the attach2post function in the media library.

    Warning: Call-time pass-by-reference has been deprecated in /home/notroot/develop/wordpress/wp-content/plugins/add-from-server/class.add-from-server.php on line 137

    Also, the plugin can’t handle a ‘&’ in the path.

    Cheers

Viewing 1 replies (of 1 total)
  • Plugin Author Dion Hulse

    (@dd32)

    Hey dajense,
    Thanks for reporting this.

    That PHP Warning should not be displayed at all by WordPress, the Default (and even Debug) error reporting levels are to ignore PHP5 deprecated messages such as that..

    However, Since it wasn’t required to be like that, I’ve updated the plugin to avoid that. See [428881] for that, and [428887] to add some more HTML Escaping.

    I’ll push a new version of the plugin over the next week or so.

    D

Viewing 1 replies (of 1 total)
  • The topic ‘Deprecated function and characters not properly escaped’ is closed to new replies.