Support » Plugin: Flat / Table Rate Shipping For WooCommerce » Deprecated code in: class-advanced-flat-rate-shipping-for-woocommerce-admin.php

  • Resolved k4satin

    (@k4satin)


    The plugin works, but when I run WP in debug mode, I’m getting this warning:

    Deprecated: Required parameter $json follows optional parameter $selected in …/wp-content/plugins/woo-extra-flat-rate/admin/class-advanced-flat-rate-shipping-for-woocommerce-admin.php on line 2951

    This is followed by several “cannot modify headers” errors all referencing back to this file and this line.

    I’m using the latest version 3.9.5. Are you working on this?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Hitendra Chopda

    (@hitendra-chopda)

    Hello k4satin,

    Thanks for contacting us and apologies for the inconvenience.

    Can you please change as mentioned below and might it will work for you.

    Line no: 2951

    From: $json

    To: $json = ”

    We are looking into this and resolve it in our upcoming version.

    Best Regadrs,
    Hitendra & Dotstore Team

    marcoshuss

    (@marcoshuss)

    It’s working for me to, the line stay like that:

    public function afrsm_pro_get_category_options( $selected = array(), $json=”” )

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.