Support » Fixing WordPress » Deprecated class-simplepie.php

  • Resolved Bloke

    (@bloke)


    On my dashboard I get this error about 50 lines of:
    Deprecated: Assigning the return value of new by reference is deprecated in …..\wp-includes\class-simplepie.php

    in the plugins panel and I read it has to do with the simplepie.php being out of date. But why would my local version show this error and my online version not? They use the same version PHP (5.3), WordPress (3.4.2) and same plug ins and same theme.

Viewing 3 replies - 1 through 3 (of 3 total)
  • That it doesn’t show on your online version but it does on your local version probably is caused by the WP_DEBUG constant to be true in your wp-config.php. This will write all errors you get. On online version the error reporting is usually off or only to log files ( wisely so!)

    My local version is define(‘WP_DEBUG’, false);

    Also tried the trick opened class-simplepie.php and replaced all ‘=& new’
    with ‘= new’ it changed 116 instances but still get the errors.

    The errors went away. I copied the version of class-simplepie.php I was using on the online version. Also changed error reporting in PHP.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Deprecated class-simplepie.php’ is closed to new replies.