Support » Plugin: Track, Analyze & Optimize by WP Tao » Deprecated Calls

  • Resolved jurasjo

    (@jurasjo)


    hi

    I think this plugin should be updated because there was a major update in Woocommerce(now 3.0.6) and there is a lot of deprecated calls initiated by WP Tao.
    SCREEN

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Michal Jaworski

    (@upsell)

    Hi @jurasjo,

    Thanks for the info. We will release the new version of the Tao shortly.
    Stay tuned!

    Regards
    Michal

    thank You

    Plugin Author Michal Jaworski

    (@upsell)

    Hi @jurasjo,

    We’ve just released WP Tao 1.2.7. It’s now fully compatible with new version of WooCommerce.

    Hi. Super.

    One question: is new version also backward compatible (Woocommerce 2.6.14)?

    Plugin Author Michal Jaworski

    (@upsell)

    Hi @jurasjo,

    Yes, it is 🙂

    Hi

    I have installed newest version of WP Tao and Woocommerce 3.0.9 and those calls are still there.

    SCREEN

    I think those calls are related to payment.php file.

    • This reply was modified 3 years, 4 months ago by jurasjo.
    • This reply was modified 3 years, 4 months ago by jurasjo.

    Also order.php and payment.php (get_order_currency)

    Plugin Author Michal Jaworski

    (@upsell)

    Hi @juraso,

    Are you sure you have newest version of Tao?

    Yes. I use newest version 1.2.7.

    Looks like for the Woocommerce 3 line 44 in the order.php (in the events directory should have get_currency() instead of get_order_currency() ) and in the file payment.php (in the same directory) line 36 should have get_shipping_first_name(), line 37 get_shipping_last_name(), 40 – get_billing_email() and line 54 – $order->get_currency().

    Of course those are for Woocommerce 3.

    Plugin Author Michal Jaworski

    (@upsell)

    @jurasjo,

    OK, we’ve got it. 1.2.8 version is just coming.

    I ahve updated to version 1.2.8 and now there are notices like shown below.

    [12-Jul-2017 05:16:14 UTC] billing_email was called incorrectly. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::do_wc_ajax, do_action('wc_ajax_checkout'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::checkout, WC_Checkout->process_checkout, do_action('woocommerce_checkout_order_processed'), WP_Hook->do_action, WP_Hook->apply_filters, wtbp_wptao_event_sale_woo_fire, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong. This message was added in version 3.0.
    [12-Jul-2017 05:16:14 UTC] shipping_first_name was called incorrectly. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::do_wc_ajax, do_action('wc_ajax_checkout'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::checkout, WC_Checkout->process_checkout, do_action('woocommerce_checkout_order_processed'), WP_Hook->do_action, WP_Hook->apply_filters, wtbp_wptao_event_sale_woo_fire, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong. This message was added in version 3.0.
    [12-Jul-2017 05:16:14 UTC] shipping_last_name was called incorrectly. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::do_wc_ajax, do_action('wc_ajax_checkout'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::checkout, WC_Checkout->process_checkout, do_action('woocommerce_checkout_order_processed'), WP_Hook->do_action, WP_Hook->apply_filters, wtbp_wptao_event_sale_woo_fire, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong. This message was added in version 3.0.
    [12-Jul-2017 05:16:14 UTC] The WC_Order::get_order_currency function is deprecated since version 3.0. Replace with WC_Order::get_currency.
    

    SCREEN

    I use newest Woocommerce 3.1.1.

    • This reply was modified 3 years, 3 months ago by jurasjo.
    Plugin Author Michal Jaworski

    (@upsell)

    @jurasjo,

    It looks like never ending story 😉
    Maybe WooCommerce version checking mechanism works wrong. We are checking…

    Plugin Author Michal Jaworski

    (@upsell)

    @jurasjo,

    OK, the update is coming… I hope this time everything will be OK 🙂

    I believe everything is ok now. Thank You.

    Plugin Author Michal Jaworski

    (@upsell)

    @jurasjo

    Don’t believe – check it 😉

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Deprecated Calls’ is closed to new replies.