Support » Installing WordPress » deployment on raspberry pi3

  • Hi,

    I have done a website based on wordpress on my wampserver install.

    I have copied all the content of WWW folder
    I have export and import teh database and updatet the url inside.

    I have update wp-config.php

    define('DB_NAME', 'site_bdd');
    define('DB_USER', 'myuser');
    define('DB_PASSWORD', 'mypassword');
    define('DB_HOST', 'localhost');

    When I’m trying to access to my website I get white page.

    I do not understand why ?

    I have tryied my Raspberry pi install with index.html from apache2 and with a basic phpinfo file.

Viewing 13 replies - 1 through 13 (of 13 total)
  • That means that there’s “some error”, but your settings have the error output disabled. That’s what’s set by default to prevent unwanted eyes from seeing error messages that could contain useful (to hackers) information.

    To see what the error is, change this line in your wp-config.php file:

    define('WP_DEBUG', true);

    That will enable error reporting and show all of the errors and warnings that you’re getting.

    If I put this to true, I got no output only white on my page

    Then you’ll need to do more de-bugging, and look at the serverlogs that you have available there to see what errors they show.

    First thing is to disable all (yes, ALL) plugins, and revert to a default (Twenty *) theme. That will eliminate any possible issues with plugins or theme. If that doesn’t help, that’s when the server logs will be able to tell you what is going wrong.

    Unfortunately there’s really no way for anyone here to be able to tell you what your specific issue is as we obviously don’t have access to your system.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Are you running Raspibian Jessie Lite or the full Raspian distro?

    I’m running the full jessie distrib with IHM

    I do not if some module for apache are missing or what happenned
    full html and phpinfo() function are working not wordpress

    Hi

    I have try a new install of wordpress. It is working.

    I have done exactly the same with my website but not with same settings.

    I do not understand why, I use wamp server for apache and phpmyadmin without any tunng.

    I have spent a lot of time to create all the content of the website, How can I export it if I can not migrate the full site ?

    For theme and plugin, I could try to install theme one by one
    but for settings and content I do not know how.

    What extra de-bugging did you try? What do your servers log files tell you?

    I have had this before too. And it did come down to me checking error log files, server logs and what ever other server messags I could find. For my case – which is most likely not the same as yours – it came down to function names being called with capitals in function names (Windows didn’t complain about myfunction vs. myFunction where *nix did).

    There’s always a reason for things like this, as I’ve shown above, but unless you know the actual error message it’s very difficult to actually say what to fix because there’s just too many possible variations that no one could be expected to know.

    Hi,

    I have read all error messages, I have got only access 43 error. I have update right but wordpress is not working.

    Today I have done a new fresh install on my server. I have installed all plugins and themes. It is fine .
    I have only one problem. I’m migrating from wampserver to a real raspberry pi server but, the import function in tools-> import propose me only importation of content trhough ftp. How can I give it the WordPress extended file export from my local install ?

    or how can I add it all my content and settings ?
    I have worked on wamp to due the amount of content that I have to create 200 pots, 700 custom poss and 15 pages

    I think the use come from data format as utf8 or utf8mb4 on mysql.

    It’s the only reason that shoumd create this type of problem. I have find no error on apache on php to explain the prolem. On my wampserver, I have done all update and it is always working fine. I do not find other differencies.

    • This reply was modified 2 years, 11 months ago by benoitf92.

    Personally I don’t do export and import through the WordPress admin area. While it does work well for most cases, the sites that I move normally are pretty complicated.

    What I’d suggest to do is move it all manually. Copy all of the sites files across, save a database dump from your development area, and import it into the database on your live server. Then update the details in wp-config.php and run a script to update the URL’s in the database (I normally use this one). After that the site should be up and running on the live site – unless there’s any pesky configuration issues from moving between platforms.

    OK
    I have tried to use this procedure by trasferring data and database, but I got white screen. Before creating this post. I have tried this.

    Now I have a wordpress running without my data. I will retry to use my full database with data.

    Hi,

    Here is the process to migrate the website from the staging or localhost to live server.

    – First get complete project folder outside from the root directory.
    – Then get the export database from MySQL or whatever database you have used.
    – Then place complete project folder and database file in a single folder.
    – Now replace the URL throughout that folder using your favourite editor.
    – Replacement of URL should be like this
    – Staging or localhost – example.com
    – Replace with the live domain like livewebsiteurl.com
    – Then follow the normal process like placing complete project folder on root directory on server.
    – And import database.
    – Then make sure you have entered correct credentials on WP-COnfig.PHP.
    – You will get live now 🙂

    Regards,
    Anil

    Thanks, I have already tried this first.

    I will try it this week end. I hope this time it will work fine.

    Hi,

    I have done a full new install of wordpress n my raspberry pi server.
    Next I have replace the content of WWW folder by my content from my local wampserver wwwfolder
    The default wordpress is always working.
    When I upload my database from wampserver to my phpmyaddmin on my raspeberry pi server and modified my wp-config.php to access to this new database my wordpress is white only white.

    I have used this to set up the server:
    http://raspbian-france.fr/installer-serveur-web-raspberry/
    http://raspbian-france.fr/mettre-en-ligne-serveur-web-raspbian-dydns-port-forwarding/

    I got the same problem.

    The default wordpress is working on both wampserver and raspberry pi but my website only on wampserver

    I use following plugin:

      backwpup
      black-studio-tinymce-widget
      contact-form-7
      contact-form-7-simple-recaptcha
      google-analytics-dashboard-for-wp
      jetpack
      simple-login-log
      tinymce-advanced
      widget-visibility-time-scheduler
      wp-mail-smtp
      wps-hide-login
      wp-super-cache (present but inactive)

    I have no error on php or apache2 log.

    I do not understand what happened. I think about importing posts manually if possible

    Do you have any idea to solve that ?

    I think it come from database format or database settings

    • This reply was modified 2 years, 11 months ago by benoitf92.
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘deployment on raspberry pi3’ is closed to new replies.