Support » Plugin: Duplicator - WordPress Migration Plugin » Deploying through special hosting co port resulted in port # being added to URL

  • Resolved DGLauren


    I used Duplicator on one site with all the same versions/setups and it worked perfectly.

    My second site was much larger, and I ran into this when trying to set up my subdomain: “504 Gateway Time-out… the server didn’t respond in time” so I contacted the hosting company to see if my max_execution_time in PHP configurations could be increased beyond 6 minutes. Instead, they opened a specific port that stays open without limit and kept it open, letting me go through that, until deployment was complete. It took 8 minutes, instead of 6.

    Everything looked great, the test at the end looked fine. They closed the port and I said goodnight.

    Then, the problems began. By using that port, the port number was somehow added to the URLs of everything in my database, including the basic site address. If I typed my subdomain name into the browser window and hit Enter, it was immediately replaced with the same URL plus the port number ( and in Google Chrome, I’d get a msg: “Oops, Chrome cannot connect to..” (URL with the :81)

    Level 1 techs worked on it and I was able to get back in, but afterward the images were all broken-linked, as each had :81 in its path.

    After hours worth of wrangling around in my site’s intestines, Level 2 techs at the hosting company manually removed the :81, images were back, but over and over, login problems still persist.

    Probably didn’t need all of the above to ask my main question: Have you ever before encountered the deployment through a special hosting port rewriting the URLs of content to include their port number? (convoluted sentence…sorry)

    I wish I’d tried your suggestion for adding a line to the .htaccess file first, instead of hoping for a time extension from the hosting company.

    I will greatly appreciate any light you can shed on this (and will wait to hear from you before I start over from scratch with these two test subdomains). Thank you

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle


    Hey DGLauren,

    Yeah that definitely seems like a strange approach to enabling the timeout or throttling settings imposed by your host. To be honest I’m not sure how the port got added to your existing sites data. Does the database.sql file that is inside the archive file have the port number added to it? You might have to check the wp_options table and the wp-config.php manually to see if the port number is somehow set there as well, I have never talked with anyone who tried that approach, so I’m not really sure where the underlying issue resides…


    Thanks for getting back to me! I’ll check everything you suggested and see what I find. I’ve had so many people at the hosting company tinker around with it, though, that I’m thinking the best thing to do is delete my subdomains and start again. This time, I’ll try your suggestion re the .htaccess file and if that doesn’t work, I’ll exclude the wp-content directory.

    Is uploading manually as simple as just copying the directory and pasting it into the proper place in the subdomain’s root directory? (I should create and name a directory for it in advance, right?)

    Thanks again!

    Plugin Author Cory Lamle


    Check out the Quick Start Guide it will run you through the simplest approach to getting it going…

    Hi, Corey! Sorry it took a couple of days to get back to you, but I’ve been pretty busy troubleshooting and running trials on the different methods of working around timeout issues. I can see now that I should have been clearer in my last question. I’ll clarify, for the benefit of others who might come here searching for solutions:

    In your FAQ, Section 3 – Troubleshoot/Timeout Issues, Point # 10, you suggest the option of using the package creation filters to exclude the wp-content/uploads folder to reduce the size of a large website. My question was if I could then just copy that folder and paste it into the cloned subdomain once the package had been deployed, if it was that simple.

    As it was, I didn’t have to go that route. First, I tried editing the “timing” rule into the .htaccess file and that option didn’t work for me, but the method of using Manual Extraction worked like a charm!

    It was nice to know I had yet another option to try (excluding wp-content from the pkg creation) before going back to the host company’s tech support for help, but I was just really happy when manual extraction worked and I didn’t have to go any further.

    Thank you for creating such a fantastic plugin, and thanks TWICE that much for providing such great tutorials on your product. Already, I recommend WordPress Duplicator to everyone.

    Plugin Author Cory Lamle


    Excellent! Glad you where able to make things work!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Deploying through special hosting co port resulted in port # being added to URL’ is closed to new replies.