• Hello,

    I’ve been trying to upload my site to my host (godaddy – Linux hosting with cPanel) using the duplicator plugin, however, I keep getting errors…

    (I am aware that godaddy has issues with this, however its not my account and I cannot change hosts!)

    Before I begin, I make sure I pass all requirement and test connection. I am good there. I set up the SQL database in cPanel and use phpmyadmin to remove all the tables so there are no duplicates.

    I am using the correct host, user, name, and password.

    I keep getting this error…

    DATABASE RESULTS
    ————————————–
    **ERROR** database error write ‘Incorrect string value: ‘\xF0\x9F\x99\x82″ …’ for column ‘option_value’ at row 1′ – [sql=INSERT INTO wp_options VALUES(“1906”, “_transient_feed_d117b5738fbd35bd8c…]
    **ERROR** database error write ‘Incorrect string value: ‘\xF0\x9F\x8F\xB3” …’ for column ‘option_value’ at row 1′ – [sql=INSERT INTO wp_options VALUES(“1902”, “_transient_feed_ac0b00fe65abe10e0c…]
    ERRORS FOUND: 2
    DROP TABLE:
    QUERIES RAN: 1374

    wp_blog_versions: (1)
    wp_blogs: (1)
    wp_commentmeta: (0)
    wp_comments: (1)
    wp_duplicator_packages: (2)
    wp_links: (0)
    wp_options: (219)
    wp_postmeta: (539)
    wp_posts: (389)
    wp_registration_log: (0)
    wp_signups: (0)
    wp_site: (1)
    wp_sitemeta: (55)
    wp_term_relationships: (76)
    wp_term_taxonomy: (13)
    wp_termmeta: (0)
    wp_terms: (13)
    wp_usermeta: (42)
    wp_users: (1)
    Removed ’24’ cache/transient rows

    SECTION RUNTIME: 3.8120 sec.

    ********************************************************************************
    STEP1 COMPLETE @ 11:57:55 – TOTAL RUNTIME: 102.9835 sec.
    ********************************************************************************
    ********************************************************************************
    START FINAL CLEANUP: 11:59:05
    ********************************************************************************
    Update MU table blogs: domain ****************.com

    ————————————–
    NOTICES
    ————————————–
    WP-CONFIG NOTICE: The wp-config.php has one or more of the following values set [WP_CONTENT_DIR, WP_CONTENT_URL, WPCACHEHOME, COOKIE_DOMAIN, WP_SITEURL, WP_HOME, WP_TEMP_DIR]. Please validate these values are correct by opening the file and checking the values.

    WEB SERVER CONFIGURATION FILE BASIC SETUP:
    created basic .htaccess file. If using IIS web.config this process will need to be done manually.
    ********************************************************************************
    STEP 2 COMPLETE @ 11:59:05 – TOTAL RUNTIME: 0.7142 sec.
    ********************************************************************************

    I am not sure where to go from here. I have tried over and over. I removed WP-SuperCache plugin as that was seeming to cause issues and made a new package. What am I doing wrong?

    Thanks in advance for your help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    What version of MySQL is GoDaddy running on that server? It will also show in the log file…

    From the log…

    MYSQL VERSION: This Server: 5.6.30 — Build Server: 5.7.11
    TIMEOUT: 5000
    MAXPACK: 268435456

    The versions were close enough that I thought it shouldn’t make a difference. I will contact godaddy and have them update the MySQL on their end just to be sure.

    EDIT…

    Strangely enough, godaddy support said:

    “Currently all shared hosting accounts on cpanel has a default seting of MySQL 5.5.35. There is currently no option to upgrade the version at this time.”

    • This reply was modified 2 years, 7 months ago by  COSenna.
    Plugin Author Cory Lamle

    (@corylamleorg)

    That is very odd… The call in the plugin to get the version on GD uses a core PHP lib:
    http://php.net/manual/en/mysqli.get-server-info.php

    So either PHP or GD is not reporting back the correct info.

    In anycase with you running at least 5.5 the mysql version should not be an issue. The problem I believe is that the table collation type for the wp_options table on the GD server isn’t set to the same collation as the server you built it on. You may need to work with GD support to change the table collation to match.

    Here is an overview of the issues:
    http://stackoverflow.com/questions/10957238/incorrect-string-value-when-trying-to-insert-utf-8-into-mysql-via-jdbc

    Let me know if that helps!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Deploy Errors’ is closed to new replies.