Support » Plugin: Flexible Checkout Fields for WooCommerce » Dependency conflict

  • Resolved billcv

    (@billcv)


    I am getting the following error in the admin console after updating:

    The “flexible-checkout-fields-pro/flexible-checkout-fields-pro.php” plugin cannot start as there is a dependency conflict with other existing plugin. Please upgrade all plugins to the most recent version.

    Apparently it is also preventing people from checking out, so I have had to disable the plugin.

    All other plugins are up to date.

    Is there any way to find out what the dependency is. That would help to narrow it down without having to test every other plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor dyszczo

    (@dyszczo)

    Hi @billcv,

    If you have WP Desk Helper plugin please disable it. It’s no longer needed.
    If this does not help could you provide list of installed plugins?

    Best regards,
    dyszczo

    billcv

    (@billcv)

    That solved the problem. Thanks!

    mittychang

    (@mittychang)

    @dyszczo

    I’m having the same problem as billcv reported. I also receive the “The “Flexible Checkout Fields PRO” plugin cannot start as there is a dependency conflict with other existing plugin. Please upgrade all plugins to the most recent version.” error message when my Flexible Checkout Fields PRO plugin is activated. This started occurring with the June 6 plugin update. I have the latest WordPress, v5.2.2, and all other plugins are up to date.

    I have deactivated and deleted the WP Desk Helper plugin as this thread recommended, but that did not fix the situation.

    Additionally, I have also downloaded fresh copies from the wpdesk.net site of both the Flexible Checkout Fields plugin and the Flexible Checkout Fields Pro plugin, and uploaded both of these freshly downloaded copies to my plugins folder to see if that would fix it — it did not fix the issue.

    Since this error does affect the frontend checkout, I have had to leave the Pro version deactivated.

    Any other suggestions? I have also submitted a Pro support ticket as well, but thought I would try this forum too since I am assuming others are having this issue as well.

    Woocommerce version 3.6.4
    Flexible Checkout Fields version 1.9.3.
    Flexible Checkout Fields Pro version 1.10.1

    Other active plugins installed:

    Advanced Custom Fields PRO: by Elliot Condon – 5.8.1
    Akismet Anti-Spam: by Automattic – 4.1.2
    Aleman Orders Customization: by Nicu Aleman
    Aleman Inc – 1.0 – Not tested with the active version of WooCommerce

    amr shortcode any widget: by anmari – 3.7
    WooCommerce Authorize.net AIM Premium: by Indatos Technologies – 9.6 – Not tested with the active version of WooCommerce
    CallTrackingMetrics: by CallTrackingMetrics – 1.2.3
    Contact Form 7: by Takayuki Miyoshi – 5.1.3
    Debug This: by Brian Fegter
    Chris Dillon – 0.6.1

    Duplicate Post: by Enrico Battocchi – 3.2.2
    Google Tag Manager for WordPress: by Thomas Geiger – 1.9.2 – Not tested with the active version of WooCommerce
    Flexible Checkout Fields: by WP Desk – 1.9.3
    Fusion Builder: by ThemeFusion – 1.9.1
    Fusion Core: by ThemeFusion – 3.9.1
    Dynamics 365 Integration: by AlexaCRM – 1.2.20.2
    Kadence WooCommerce Email Designer: by Kadence Themes – 1.2.1
    Kraken Image Optimizer: by Karim Salman – 2.6.4
    Ninja Forms: by The WP Ninjas – 3.4.15
    Redirection: by John Godley – 4.3.1
    Relevanssi: by Mikko Saari – 4.2.0
    Show Current Template: by JOTAKI Taisuke – 0.3.0
    Simple Sitemap: by David Gwyer – 3.0
    Smart WooCommerce Search: by YummyWP – 1.5.10
    The Events Calendar: by Modern Tribe
    Inc. – 4.9.3.1

    UpdraftPlus – Backup/Restore: by UpdraftPlus.Com
    DavidAnderson – 1.16.15

    User Role Editor: by Vladimir Garagulya – 4.51.1
    Dynamics CRM Orders Sync – WooCommerce: by Lyubomir Toshev
    ViceSoft – 2.2 – Not tested with the active version of WooCommerce

    Woocommerce Cart Limit: by Webman Technologies – 1.1 – Not tested with the active version of WooCommerce
    Woo Discount Rules: by Flycart Technologies LLP – 1.7.16
    WooCommerce Admin: by WooCommerce – 0.13.2
    WooCommerce Stripe Gateway: by WooCommerce – 4.2.1
    WooCommerce Google Analytics Integration: by WooCommerce – 1.4.9
    WooCommerce Order Status Control: by SkyVerge – 1.10.0 – 1.10.1 is available – Not tested with the active version of WooCommerce
    WOOF – WooCommerce Products Filter: by realmag777 – 1.2.2.1 – Not tested with the active version of WooCommerce
    WooCommerce: by Automattic – 3.6.4
    Wordfence Security: by Wordfence – 7.3.4
    WordPress Importer: by wordpressdotorg – 0.6.4
    Yoast SEO: by Team Yoast – 11.4 – Not tested with the active version of WooCommerce
    WP Mail Logging: by Christian Zöller – 1.9.1
    WP Mail SMTP: by WPForms – 1.4.2
    Smush Pro: by WPMU DEV – 3.2.1
    WPMU DEV Dashboard: by WPMU DEV – 4.7.1.3

    Plugin Contributor dyszczo

    (@dyszczo)

    Hi @mittychang,

    now you have basically only:
    – Flexible Checkout Fields version 1.9.3.
    – Flexible Checkout Fields Pro version 1.10.1
    as the plugins that use libraries so there should be no conflict.

    Is there something in the log files?

    You have submitted the ticket to the pro support team, so they will probably solve this problem faster than I 🙂

    Plugin Support ospiotr

    (@ospiotr)

    As we haven’t got any replies, I’m marking this topic as resolved for now.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.