Support » Plugin: WP Offload SES Lite » Delivery failures and I’m baffled.

  • cowbelly

    (@cowbelly)


    [19-Jul-2019 02:58:17 UTC] WP Offload SES #202: There was an error attempting to send your email. (Error executing "SendRawEmail" on "https://email.us-west-2.amazonaws.com"; AWS HTTP error: Client error:POST https://email.us-west-2.amazonaws.comresulted in a400 Bad Request` response:
    <ErrorResponse xmlns=”http://ses.amazonaws.com/doc/2010-12-01/”&gt;
    <Error>
    <Type>Sender</Type>
    InvalidPara (truncated…)
    InvalidParameterValue (client): Expected ‘;’, got “:” – <ErrorResponse xmlns=”http://ses.amazonaws.com/doc/2010-12-01/”>
    <Error>
    <Type>Sender</Type>
    InvalidParameterValue
    <Message>Expected ‘;’, got ":"</Message>
    </Error>
    <RequestId>4752795d-1d67-4035-9758-ceef0db6ab0c</RequestId>
    </ErrorResponse>
    )’

Viewing 14 replies - 1 through 14 (of 14 total)
  • cowbelly

    (@cowbelly)

    Anyone have any idea what/where this problem is originating?

    InvalidParameterValue (client): Expected ';', got ":"

    cowbelly

    (@cowbelly)

    There’s definitely an issue with the Plugin.

    I sent multiple test emails directly from Amazon SES and they delivered fine with no issues.

    I also sent test emails through Wordfence and they delivered fine with no issues, but in the WP Offload SES admin there is a delivery failure notice next to those emails.

    I also changed the email address in the WordPress admin in general settings and had no problems with the verification and confirmation emails getting through.

    But, there are some emails that are being marked as failed by WP Offload that are *not* delivering, and those are the ones I care most about, because they are emails that get sent after site users subscribe to an optin form.

    I tested the same optin form with WP Offload disabled, and they went through just fine.

    So the only constant problem in all these scenarios is WP Offload SES.

    It’s really unfortunate, because my business has recently switched to a full-service agency providing web services to clients and I had planned on upgrading the plugin and also asking our clients to upgrade to the premium plugin on their sites. But that’s not going to happen now since I can’t reliably count on an plugin that doesn’t work even with the simple free version.

    cowbelly

    (@cowbelly)

    I also wanted to mention that this behavior is occurring on three different websites, each with different plugins and different themes, and two with e-commerce and one without.

    All emails and domains are verified with Amazon SES.

    I’m convinced it’s the plugin and am abandoning it for something that inspires more confidence in purchasing a premium version.

    cowbelly

    (@cowbelly)

    One last thing:

    In the warning message that you can’t get rid of that appears at the top of every page in your WP admin, the line:

    ‘check out our doc for debugging failed emails.’

    Leads to a 404 not found page on the developer’s website.

    If this is the strategy they use to try and get people to upgrade in order to get any kind of support, it’s not working.

    x1ngxang

    (@x1ngxang)

    Cowbelly I’m right up there with you. Do you know of an option that works? This plugin had potential. But the API has some critical internal issues.

    cowbelly

    (@cowbelly)

    I’ve been searching but haven’t found the perfect alternate solution. This would be an ideal opportunity for another developer to jump in and create a competing product that works.

    The only alternate I can find is to set up SMTP in Amazon SES and then use one of the SMPT plugins like WP Mail SMTP by WPForms (which has 1+ million downloads and a 4.5 star review average, which is phenomenal.)

    I just read a couple of other ‘resolved’ support threads for this (offload SES) plugin where the people’s only resolution was to switch to SMTP.

    So I guess that’s it! I’m off to create my SMTP credentials.

    cowbelly

    (@cowbelly)

    Ok it looks like I found the solution, which was proposed by another user who posted problems many months ago.

    I rolled the plugin version back to 0.8.2 on two of our websites (using the free plugin WP Rollback), created two new IAM Amazon users, generated new keys, and then tested both sites using Wordfence, and two different plugins- send email and check email, and all appears to be working as it should. (Finally…)

    This leads me to believe that it’s an issue with the latest version of the plugin. Some code gone awry.

    Side note- when you send test emails using Wordfence (very bottom of the diagnostics tab in tools) it actually tells you right then and there if the result Wordfence receives from the WordPress wp_mail() function is true (success), or false (delivery failure). With the current version of WP SES Offload enabled, the result is false every time. After rolling back it’s true every time.

    Hopefully it stays that way! I just have to remember to NOT upgrade to the latest version!

    Hope that works for you x1ngxang, and anyone else reading this.

    x1ngxang

    (@x1ngxang)

    I just followed your directions and YOU are Awesome. It works perfectly, even with my original IAM credentials.

    The previous version has – in my opinion – a much better interface and more useful transactional log. I am staying with 0.8.2. Thank you!

    cowbelly

    (@cowbelly)

    Awesome!!

    I totally agree with you 100% about the original interface. This situation reminds me of Apple. I always want to tell them “if it ain’t broke don’t fix it!”

    Glad to hear it worked for you, and hopefully it will work for others in the same boat.

    Hi @cowbelly,

    I just wanted to give you a heads up that we’ve identified the reason for the error that you ran into and a fix will be included in the next release. Were you only noticing that error when sending emails via Wordfence?

    Good to hear Matt!

    I’m still using the plugin, rolled back to 0.8.2, and not having any issues with it at all.

    No, it wasn’t just Wordfence emails that were the issue.

    I was having delivery failure problems with ALL emails coming from the site. From Woocommerce, Wordfence, a coupon plugin (I spoke to the developer and he had no idea why it wouldn’t work), a reminder plugin, and test emails from the WordPress admin itself when changing the email address in general settings. So it was virtually everything.

    The only error I ever saw in the logs was: Expected ‘;’, got “:”, and I haven’t the foggiest idea where that originates. I tried looking at the Offload SES plugin files but gave up pretty quickly, lol.

    One thing I discovered that’s a bit odd is this:

    One of my sites has a different theme installed, and I tested the whole troubleshooting process on it with the exact same plugins the problematic sites have. Same exact settings, same everything, same caching settings, just different theme. Had zero problems with Offload SES on that one site.

    BUT, my Divi site and TheGem sites had nothing but problems. So perhaps it’s a theme compatibility issue with the current version, hence the reason why some people have critical issues and some don’t? Just wanted to mention that in case it helps.

    I really love the Offload SES plugin, and I meant what I said above about being interested in the pro features, so I’m holding out hope that you guys can get to the bottom of the problem. (insert praying hands emoji here.)

    Thanks for responding.

    Update:

    I think I finally figured out the problem.

    Somehow the plugin was updated automatically on one of our sites two days ago, and we discovered that the emails started failing again.

    This was the error message we received when trying to send a test email via the WP Offload SES admin.

    Error executing "SendRawEmail" on "https://email.us-west-2.amazonaws.com"; AWS HTTP error: Client error:POST https://email.us-west-2.amazonaws.comresulted in a403 Forbiddenresponse: <ErrorResponse xmlns="http://ses.amazonaws.com/doc/2010-12-01/"> <Error> <Type>Sender</Type> <Code>InvalidClie (truncated...) InvalidClientTokenId (client): The security token included in the request is invalid. - <ErrorResponse xmlns="http://ses.amazonaws.com/doc/2010-12-01/"> <Error> <Type>Sender</Type> <Code>InvalidClientTokenId</Code> <Message>The security token included in the request is invalid.</Message> </Error> <RequestId>cdd5b470-dd72-40a7-8ceb-ca94dbce36cc</RequestId> </ErrorResponse>

    I discovered that when upgrading the plugin, somehow the secret access key was stripped from the settings. Since that key isn’t shown in the settings it wasn’t immediately apparent.

    I deleted the access keys settings, re-saved, and then input them again, resaved again, sent a test email and it succeeded.

    We are storing the keys in the database. Would I be correct in assuming that if we place them in the wp-config file that this won’t happen again upon updating the plugin?

    Thanks Matt!

    Well, I spoke too soon.

    None of our Woocommerce or Woo-associated emails are sending using the current version.

    Along with Woocommerce, we use two different plugins that both send emails regarding coupons- one a coupon upon subscription, that has a hook to Woo, and a second that is a reminder of the Woo coupon, sent by the other plugin.

    The Woo emails (order receipts to customers, notifications to us, shipping emails, etc) are not sending at all with 1.2.1, and neither are any emails from the two Woo-linked plugins.

    I don’t know if WordPress itself is sending emails, because we rolled back the WP Offload SES plugin before we could determine that.

    With v.1.2.1 ALL test emails sent, through Wordfence diagnostics, our Check Email plugin, and through the WP Offload SES all work just fine.

    So I don’t know if this is just an issue with Woo-linked emails?

    Rolling back to 0.8.2 again fixes the problem.

    Ok, it does look like our issue is directly related to Woocommerce and woo-hooked emails.

    We have one website that doesn’t have Woo, and this evening we updated WP Offload SES to v1.2.1 and shortly thereafter received a form submission from a potential client.

    We received the email right away and the email shows as sent in the WP Offload activity tab.

    Sorry we weren’t able to get log reports. The Woocommerce emails were too important to spend time testing.

    FWIW, both the ecommerce sites experiencing problems with v.1.2.1 use TheGem theme.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.