Support » How-To and Troubleshooting » Delicious feed on WordPress

Delicious feed on WordPress

  • Hi,
    As of today, I’m experiencing problems in retrieving my Delicious feed and publish a few items of this feed on my blog hosted on Aruba.

    The problem is present only with the feed from Delicious and only on blogs hosted on Aruba (an Italian hosting provider). I tried my code on 4 different domains (hosted on Aruba) and all have this problem. Other blogs, hosted by different providers, do not have any issue in fetching a Delicious feed. Also my LAMP server on localhost fetches any feed correctly.

    On Aruba, I tried to fetch a feed from Google Reader and other services with success. Only Delicious seems to be “un-fetchable”.

    The message I receive is:

    Fatal error: Call to undefined method WP_Error::get_item_quantity() in path/to/script/delicious.php on line 16

    The code I use is here: http://aldolat.pastebin.com/m21af4a8d (valid for a month).

    The origin of the problem seems to be my hosting provider. Can you tell me if it may be possible and which configuration may be the reason for this problem?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I see this is fresh, so I won’t start a new thread. I get a similar error.

    Warning: Invalid argument supplied for foreach() in /homepages/18/d94445343/htdocs/blog/wp-content/themes/i3theme-1-6-grassygreen/header.php on line 55

    But – this exact same code feeds a different Delicious feed just fine.
    I am using the feed based on tags, so I can have a widget “articles I’ve read” “books I’m reading”, etc.

    was this ever resolved? I’m not hosted on Aruba, but as of a few weeks ago, the delicious feed no longer worked as an rss feed widget – although the feed itself seems fine in other readers.

    It seems to be a Delicious’ problem. There is a support request here.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Delicious feed on WordPress’ is closed to new replies.
Skip to toolbar