Support » Plugin: Inline Related Posts » Deleting zeros in a table

  • matsa24

    (@matsa24)


    Hello!

    I found a bug.
    If I enable the plugin, it starts to remove zeros in the tables. For example, here is the code:

    <table>
    <tbody>
    <tr>
    <td>0</td>
    </tr>
    <tr>
    <td>1</td>
    </tr>
    </tbody>
    </table>

    When I publish, I see such content:

    1

    The plugin removed the zeros in the cells.

    If I disable the plugin, everything is OK


    0
    1

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author IntellyWP

    (@intellywp)

    Hi @matsa24,
    Thanks for choosing IntellyWP products.

    We just tested this content but everything is working correctly.

    Could you please send us more information about how could we reproduce this issue?

    We need a web page URL, or more, where we can check the source code to see what is going on and some screenshots of your plugin settings.

    I hope you can understand that, without information, it is very difficult for us to figure out how to reproduce your issue and, eventually, help you to fix it.

    Thank you

    IntellyWP

    matsa24

    (@matsa24)

    Try opening this link
    http://shopzero.ru/poleznye-sovety/hi-test/

    see the screenshot
    http://intrekl.ru/2019-02-19_145621.png

    How to repeat the problem
    Start adding a new entry. In the text field, add this code:

    <table>
    <tbody>
    <tr>
    <td>0</td>
    </tr>
    <tr>
    <td>1</td>
    </tr>
    </tbody>
    </table>

    http://intrekl.ru/2019-02-19_145840.png

    Make sure that the Inline Related Posts works on this record.

    After publishing, in the public section of the site, you will see that the plugin has removed the zeros in the table cells.

    http://intrekl.ru/2019-02-19_145621.png

    If you disable the plugin, you will see the following content:
    http://intrekl.ru/2019-02-19_150231.png

    I hope you’re getting it. Very often zeros play a very important role in tables.

    • This reply was modified 9 months ago by matsa24.
    Plugin Author IntellyWP

    (@intellywp)

    Hi @matsa24,

    I already added this code as HTML content like this screenshot
    http://intrekl.ru/2019-02-19_145840.png

    but i see the 0 on the post content

    Could you please send us a list of all installed plugins and the name of your current WordPress theme?

    Have you tried to add a space before and after the 0?

    Please let us know

    Thank you

    IntellyWP

    matsa24

    (@matsa24)

    Have you tried to add a space before and after the 0?

    If you put a space before zero, there is no problem

    I have only 2 plugins installed-Yoast SEO and WP Fastest Cache.

    I use my theme

    Plugin Author IntellyWP

    (@intellywp)

    Hi @matsa24,

    our suggestion is to add a space before 0 anyway you could edit the following file

    /wp-content/plugins/intelly-related-post/includes/classes/html/HTMLContext.php

    and replace the line 256

    $more=strpos($all, ‘>’, $less+1);

    with

    $more=strpos($all, ‘> ‘, $less+1);

    and check any errors after this customization.

    Please let us know

    IntellyWP

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Deleting zeros in a table’ is closed to new replies.