Gravity Forms Salesforce Add-on
[resolved] Deleting web-to-lead removes API as well (4 posts)

  1. Jon Brown
    Posted 3 years ago #

    Two plugins show up in the admin, one is active (API) the other is inactive (web-to-lead). When I delete the inactive one it removes the API as well.

    I tried deleting via FTP and reinstalling but it came back. Should I just remove the comment header block from the salesforce.php to hide web-to-lead or is there a better way than hacking plugin files?


  2. Zack Katz
    Plugin Contributor

    Posted 3 years ago #

    Yeah, they're in the same plugin folder. Just delete the web to lead file if you want only the API.

  3. Jon Brown
    Posted 3 years ago #

    Thanks Zack.

    We might actually be switching to the W2L version, so I'm wondering about the oposite? Does W2L require the API plugin?

    FYI, the reason is the API version isn't working pushing data to fields that aren't required for the object type. For leads, name and company work, but email isn't working. I'm not at all familiar with SF, but I think permissions are set to allow everything. When the SF guys tried restricting permissions down to just the lead object none of the object types showed as available. Wierd stuff, I think W2L is all we need anyway, hope that works.

  4. Zack Katz
    Plugin Contributor

    Posted 3 years ago #

    This may have been caused by a plugin bug. Please update to version 2.2.4 and let me know if the email is still not pushing properly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Gravity Forms Salesforce Add-on
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.