WordPress.org

Support

Support » Plugins and Hacks » Arigato Autoresponder and Newsletter » [Resolved] Deleting an imported CSV file

[Resolved] Deleting an imported CSV file

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author prasunsen

    @prasunsen

    The addresses are in the database, you can’t delete them by deleting a file. You can go to phpMyAdmin to delete them there.

    I went to phpmyadmin but cannot figure out what to alter to delete the csv imported addresses…

    What exactly do I need to do?

    Thanks much and Merry Christmas !

    Plugin Author prasunsen

    @prasunsen

    Find table wp_bft_users, go to SQL and run

    TRUNCATE TABLE wp_bft_users;

    Note that this will delete ALL subscribers. If you want to delete only the imported ones you need to know the date when they were imported and run something like:

    DELETE FROM wp_bft_users WHERE date=’2013-12-27′

    Ok…. Thanks for the explanation. The reason I asked is that I had a small list of 500 people and then I imported 500 more from another list and forgot to change the columns. Now I have 500 that need to be deleted and am doing it one by one…. 🙂

    To bad I was testing this out importing both sets on the same day… 🙂

    Is there a better way to fix this error without resending all mails to everyone by deleting and reimporting everyone?

    Plugin Author prasunsen

    @prasunsen

    OK, here’s another way. Find the first email in the imported file. Go to phpmyadmin, table wp_bft_users and search for it. Not the “id” field number. Let’s for example say it’s 501. Assuming 501, run the following query:

    DELETE FROM wp_bft_users WHERE id > 501;

    Hmmmm…. I’m sorry but I do not understand what you are instructing me to do. I am not experienced in working in this area but am learning.

    Here’s a thought. I went to phpmyadmin and found table wp_bft_users and “viewed” id. I then clicked on the email table and exported it to a excel csv file. This file contains about 8 columns of stuff. I was able to delete all the “names” rows from the “email” column rather quickly and now have just the emails in my csv file. Looking good…

    But… I have not imported it back yet as I’m not sure of the settings to use when I look at the import screen in phpmyadmin. I think I import it as a “csv” “;” delimited file? Hmmm…

    Worst case scenario ? If I screw this import up in phpmyadmin than the best option would be to empty the table and then reimport back in wordpress BFT Autoresponder and live with the restarting of the email sequence for everyone?

    I hope this makes some kind of sense to you… and I do appreciate you patience and help.

    Plugin Author prasunsen

    @prasunsen

    Um, sorry, hard to follow what you are doing. My idea was to delete the unnecessary data right into the DB table (in phpMyAdmin) rather than exporting anything. But to know which is the first wrongly imported address you need to look into that old file that you imported before.

    Sorry I don’t speak the techno language too well…. I went back in and looked at the tables again and figured out how to mass delete the addresses I needed to get rid of.

    Again… Thanks for your help and patience and I’ll wait for my trial newsletters to complete the cycle and will upgrade my free BFT Plug In.

    Is there any chance you will be offering a January special on the $87.00 Pro offer ???

    Happy New Year To You Coming Up…

    Pete.

    Plugin Author prasunsen

    @prasunsen

    Please contact me by email and I’ll ensure you’ll get a discount 🙂 We are not allowed to discuss pro versions here so please use the email for any questions.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Deleting an imported CSV file’ is closed to new replies.
Skip to toolbar