WordPress.org

Support

Support » How-To and Troubleshooting » Deleting a post “You don’t have permission to do that” message

Deleting a post “You don’t have permission to do that” message

  • Hi

    I’ve tried deleting posts as admin, author, editor and none will allow me to, I get the error message “You don’t have permission to do that”

    How do I delete a post?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Make sure that you have the permissions for the database user to run the delete query on your WordPress database set up in the database schema.

    thanks wilsonke for your reply

    where do i find the database schema? what is the url?

    I am having this same issue. Some solutions are discussed here (http://en.forums.wordpress.com/topic.php?id=1041&page=2), but none of them worked for me.

    Any help? 🙂 WP 2.1, same thing in FF & IE7. Tried to clear cache and do a “forced reload”

    Try deactivating one plugin at a time. when it works, the last plugin you deactivated is the buggy one.

    well actually that’s a suggestion since that’s what worked for me.

    I too have this issue and it has pretty much stopped me dead in my tracks at this point.

    I have tried in IE6/IE7/FireFox/Opera and none of these browsers will work. The other thing is that all of the plugins I am using used to work in the previous 2.0.x series of code releases. In addition to not being able to manage posts/categories/users I also am now having issues with themes due to the autosave feature in 2.1

    All in all I’m not too sure if this 2.1 release was throughly tested enough to be called stable or at least their needs to be some form of warning about incompatibility with plugins and themes.

    Is there a way to rvert back to an older version? It just isn’t worth it to try and use this new version with all of the issues that I am having.

    I am also having this problem, I have disabled every plugin and still have the problem. What theme are you guys using?

    Also if you go to edit > delete this page then that appears to work.

    It appears that K2 was conflicting with WP 2.1 in my case and it has been fixed in K2s latest SVN release.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Deleting a post “You don’t have permission to do that” message’ is closed to new replies.
Skip to toolbar