Support » Plugin: LiteSpeed Cache » Interaction with other plugins or theme can result in deleting menu items

  • lukesawczak

    (@wordpresspokey)


    Some cron action in this plugin, at least on WP 4.9.8, deletes nav_menu_item posts that represent pages. Finally isolated it to this and removed it for another cache plugin. This was while the Hubble Theme on Envato Market was activated, but it was still deactivating Litespeed that fixed the problem.

    The fact that the core functionality is missing if you don’t have a particular server configuration also makes it pretty limited for most purposes.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Hai⚡

    (@hailite)

    Hi @wordpresspokey,

    Sorry to know you met this issue. Our cron job didn’t have any hook to nav_menu_item. We can help debug this issue if you can give a report number.

    Best regards,
    Hai

    lukesawczak

    (@wordpresspokey)

    Well, I’m not going to reinstall it and go through that trouble when I have an alternative solution, but if you want to investigate:

    * nav_menu_item isn’t a hook, it’s a post_type

    * I found the reference to updating/deleting menu items in inc/const.cls.php

    All I know is that after turning off plugins, this is the one that stopped the problem, which was that each night the menu items were gone. It was probably an interaction with another theme or plugin if your other users aren’t having this issue, but my other plugins are non-optional, so unfortunately this one had to go. (They mostly relate to the Hubble Theme on Envato Market and the plugins built into that. I wouldn’t be surprised if there was a conflict there, because the theme has other coding problems.)

    Thinking about it, I’ll update my review to mention this.

    Plugin Support Hai⚡

    (@hailite)

    Thanks for the details you gave. We valued each user.

    I still can’t find the hook you mentioned. Apologize for this.

    We didn’t get other reports regarding the nav_menu_item yet. I agree it might be an issue related the Hubble Theme. We have contacted the author owwwlab on both Envato Market and twitter. Hopefully we can get him in touch asap to investigate this issue.

    We will try our best to eliminate all the compatibilities to get WordPress running better. If you don’t mind, please come to our slack and @ hai directly. I would like to fix this issue if possible.

    Our slack is https://goo.gl/FG9S4N

    Thanks for your update of review.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Interaction with other plugins or theme can result in deleting menu items’ is closed to new replies.