Support » Plugin: Yoast SEO » DeleteDuplicateIndexables – ERROR – Reason: Duplicate entry

  • Resolved Alias79

    (@alias79)


    After update to the last version of Yoast (14.1), this message displays to all admin users:

    DeleteDuplicateIndexables – Error executing ‘query’ with: INSERT INTO wp_yoast_migrations (version) VALUES (‘20200507054848’) Reason: Duplicate entry ‘20200507054848’ for key ‘idx_wp_yoast_migrations_version’

    The plugin has permissions to create and edit the database.

Viewing 11 replies - 1 through 11 (of 11 total)
  • This error message has disappeared after a few minutes, but I don’t know if the problem has really been solved.

    I also get this error on one of my sites. But I don’t get on others. As you mentioned, this error disappeared after a few minutes.

    Plugin Support Maybellyne

    (@maybellyne)

    Hello @alias79 @cawa-93,

    We’re really sorry that the Yoast SEO 14.1 update is causing you these problems. Can you confirm if the plugin updated successfully?

    Can you also confirm that you do have the correct permissions? Yoast SEO requires the following permissions – ALTER, CREATE, DELETE, INDEX, INSERT, SELECT, and UPDATE

    If you are using our Yoast Test Helper plugin, then we also require the DROP permission. You can also use this Yoast Test Helper plugin to recreate the indexables table. In order to do so, please take the following steps:
    1. Install & activate the Yoast Test Helper plugin

    2. On your WordPress admin page, go to Tools -> Yoast Test
    3. Hit the “Reset indexables & migrations” button
    4. Try the ‘Speed up your site now’ again via the Yoast SEO -> Tools menu

    Thanks.

    I’m getting the exact same message on one of my sites. Not sure if this is pertinent or not, but last week I upgraded this site to Yoast 14.0.4, and afterwards I tried reindexing. It started out ok, but at around 13,000 of 42,000, it failed for whatever reason, and I left it be for the time being.

    I was hoping that 14.1 would fix the issue, but as soon as I updated to the new version, that message popped up.

    Well scratch that. I went back to the site in question about 15 minutes later, and the error message had been replaced with the prompt to reindex, which I did. Everything seems to be good now.

    Plugin Support Carl B

    (@devnihil)

    @cartman Thanks for confirming that your issue was resolved after reindexing the site. Regarding the problem you had previous where the indexing failed, for sites with more than 10,000 posts, we advise using the WP CLI command to do the indexation on the server. You can read more about this here: https://yoa.st/wp-cli-index

    Try the ‘Speed up your site now’ again via the Yoast SEO -> Tools menu

    In my case the message disappeared, as I said, after a few minutes, but it is not known if the problem was really solved, or not. I’m testing this reset option, the only thing is that the process is very slow, since my website has more than 26,000 posts, something that I think was part of the problem (it takes several hours to complete).

    Ok! Now it has finished, after 6 hours, and a message has been shown saying “Congratulations, you have accelerated your site”
    Thanks!

    • This reply was modified 4 months, 1 week ago by Alias79.
    Plugin Support Carl B

    (@devnihil)

    @alias79 Thanks for confirming you were able to successfully complete the indexing. We are going ahead and marking this issue as resolved but please let us know if you require any further assistance.

    thedrap

    (@thedrap)

    Hi.. I get this same message after the update

    DeleteDuplicateIndexables – Error executing ‘query’ with: DELETE wyi FROM wp_yoast_indexable wyi INNER JOIN wp_yoast_indexable wyi2 WHERE wyi2.object_id = wyi.object_id AND wyi2.object_type = wyi.object_type AND wyi2.id < wyi.id; Reason: MySQL server has gone away

    Not only that, the update has broken my staging environment. It was constantly giving me 502 to access the backend. Got in contact with my host and found out that it was the Yoast plugin.

    Probably because the indexation never finished or I don’t know.

    I asked about the permissions and WP Engine confirmed of coarse that Yoast has all right permissions. I had to disable the plugin because of these intermitent 502 errors.

    Do you recommend run the indexation via CLI ? Don’t want to touch Prod until this is solved.

    thansk!

    After upgrading to the latest version of Yoast, I’m getting this error message:

    DeleteDuplicateIndexables – Error executing ‘query’ with: INSERT INTO wp_yoast_migrations (version) VALUES (‘20200507054848’) Reason: Duplicate entry ‘20200507054848’ for key ‘idx_wp_yoast_migrations_version’

    I had previously run the complete indexing job using WP-CLI (which took over 48 hours on my site with 60,000 posts and lots of attachments), and it had been successful. Do I have to run the whole indexing process again?

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.