WordPress.org

Forums

[resolved] Deleted /wp from WordPress Address (URL) in General Settings and now getting 404 (8 posts)

  1. seohlp44
    Member
    Posted 1 year ago #

    Deleted /wp from WordPress Address (URL) in General Settings and now getting 404 when I try to login. Also login page looks different. How can I fix this?

  2. dzawacki
    Member
    Posted 1 year ago #

    Assuming this is the installation folder, did you try re-uploading the files? Make sure that your wp-config.php contains the correct login information.

    Your content should still be in the database, but your theme, plugins, and media will be gone.

  3. seohlp44
    Member
    Posted 1 year ago #

    I literally just installed it 5 minutes ago. I did this from the General Settings Folder in WordPress.

  4. seohlp44
    Member
    Posted 1 year ago #

    Is it best to just delete wordpress and reinstall? If so how do I do that?

  5. dzawacki
    Member
    Posted 1 year ago #

    Oh, I misunderstood your question. I thought you deleted the folder on your FTP.

    I found the solution here: http://wordpress.org/support/topic/changed-the-wordpress-address-url-by-accident?replies=9

    which linked to this video post: http://educhalk.org/blog/changed-wordpress-blog-address-in-settings-locked-out-how-to-fix/

    I tested this on my own site and it worked.

  6. dzawacki
    Member
    Posted 1 year ago #

    It's a very simple fix, mine was the first row of the wp_options table. I just changed it back to what it was.

  7. Mark Senff
    Member
    Posted 1 year ago #

    If you installed WordPress in a directory called /wp/ and you want to access the site by going to the root (http://www.yoursite.com and not http://www.yoursite.com/wp), follow these instructions:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    If you can't get into your WP admin, add these two lines to your wp-config.php (and remove them once you got things running again):

    update_option('siteurl','http://www.yoursite.com/wp');
    update_option('home','http://www.yoursite.com');
  8. seohlp44
    Member
    Posted 1 year ago #

    dzawacki THANK YOU! Your solution was correct and the video was extremely helpful!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.