Support » How-To and Troubleshooting » [Resolved] Deleted page still loads?

[Resolved] Deleted page still loads?

  • I recently deleted a page that had the Permalink of “Live”. I also permanently deleted it from the trash bin.

    I wanted to make a new page with the same permalink, so I created a new “Live” page.

    However, the OLD page still appears when I go to the URL, totally ignoring anything I type in the new “Live” page. Also note that the permalink did not default to Live-2, so it is not like it’s sitting around somewhere.

    I went into the database and found no trace of it. I ran WP-Optimize, and there is no change. I cleared my browser’s cache, I pressed ctrl-F5… no matter what I do, the OLD deleted page still shows up! Why?

    I am completely baffled. I should be able to reuse this URL, but it’s not letting me. Is it hanging out somewhere that I haven’t checked?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hmmm.. have a URL? Do you have any kind of Cache plug-ins installed? Maybe it’s serving up a static html or cached version of the page that’s stored somewhere?

    Oops, sorry, forgot the link.


    That’s the URL that works… when it shouldn’t.

    And I have no caching plugins that I know of.

    Looking at that and examining the source there doesn’t seem to be much content other than an image attachment. I’d check your media library and make sure nothing is still attached or linked to that page. Looks like a live.jpg. Hmmm.. I think it’s showing it as a media page perhaps and /live/ is probably the slug for the live.jpg file.

    You’re a lifesaver.

    For whatever reason, live.jpg was redirecting to /live/. Deleting the image and reuploading it with a new filename fixed the problem.

    Thanks again!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Deleted page still loads?’ is closed to new replies.