Deleted my .HTACCESS file now my permalinks don't work (5 posts)

  1. lolattack
    Posted 7 years ago #

    I'm using Deans Permalink migration.

    My site somehow received an internal server error. I called my hosting provider and they claimed it was due to an .htaccess file.

    <IfModule mod_rewrite.c>
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    Options +FollowSymLinks
    RewriteRule submissions.html$ /submissions.php
    RewriteRule upload.html$ /upload.phpRewriteCond %{HTTP_REFERER} !^http://lolattack.com/.*$      [NC]

    Is the .htaccess file which was giving the error but it was working fine earlier.

    So now if you click on a topic at http://www.lolattack.com , it will not display anything. Any idea how to fix this? Thanks

  2. lolattack
    Posted 7 years ago #


  3. sarah11918
    Posted 7 years ago #

    I can tell you what worked for me, as I just had to migrate from old Textdrive servers to new Joyent servers, and I hope it works for you!

    I had the same issue: front page perfect, but clicking on anything resulted on a 404.

    I didn't even touch the htaccess file. Someone suggested to me it might be that file, or the permalink set up. In your admin panel, go to the tab "permalinks" and simply "update" the format of your perma links. I think this essentially "reassociates" all your links with the text on your pages from your database.

    I "updated" to the exact same format I was using. That is, I didn't change anything, I just hit the update button, then it all worked.

    Good luck! I hope that works for you!

  4. lolattack
    Posted 7 years ago #

    Worked like a charm. Thank you, Sarah.

  5. jeffbellamy
    Posted 7 years ago #

    I'll try this too. I haven't even been able to find my .htaccess file.

    I'm just trying to have my blog at my root address instead of /wordpress/

Topic Closed

This topic has been closed to new replies.

About this Topic