Support » Plugin: EWWW Image Optimizer » Deleted it due to lack of common sense

  • Just downloaded the latest version which now comes with the lovely message:

    “The next major release of EWWW Image Optimizer will require PHP 5.5 or greater. Newer versions of PHP, like 5.6, 7.0 and 7.1, are significantly faster and much more secure. If you are unsure how to upgrade to a supported version, ask your webhost for instructions.”

    That message appears in a header at the top of the page.

    Fine. I clicked on it to close it. But…it now comes up on EVERY WordPress page on my Dashboard with no way of dismantling it permanently. So….deleted the plugin, because the lack of common sense in not creating a message that can be disabled permanently after having been read and clicked on is astounding.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    The only way to dismiss that notice is to upgrade PHP. Within one month, you would have been required to either upgrade PHP or stop using EWWW IO anyway. It’s that big of a deal that I do not sit idly by and watch my users lag behind on insecure and sluggish versions of PHP: https://docs.ewww.io/article/55-upgrading-php

    corelevel

    (@corelevel)

    Deleted for lack of common sense? LOL

    You deleted it because you got a php warning message you need at least 5.5. That means you are running php 5.4 or lower.

    You are running a version of PHP that has been dead and unsupported for over 3 years. I am sure that is good for performance and security. LOL – so much for common sense.

    That you are still that out of date and mad at other people is what is astounding.

    Sure, that will work well. Treat people like dirt so they’ll use your plugin instead of someone else’s that works.

    Why are some people making php upgrades a moral issue for the bloggers instead of the hosts?

    On what planet is treating potential customers like garbage a good idea?

    You think the author was treating them like dirt because he said he will not take his time to write extra code for a free plugin to make his plugin work with an outdated insecure platform. LOL – that is funny.

    Okay, so if I say I won’t take the time to fix your car that still runs because it’s old…

    Almost no plugin has actually been free as in totally free for about a decade. Plugin developers build them without charging for the initial product with the understanding that folks are basically testing them to see if they really work and how well, so they can then make a paid upgrade or premium options.

    So we’re not even customers. We’re free testers…basically, working for the developers for free.

    So if while we’re doing this service, we’re told that they don’t see a point in dealing with our concerns because our host doesn’t do an upgrade that we can’t do ourselves, then okay…that’s their right not to see a point in it, but also our right to take our services elsewhere.

    …and if you’re going to be their lapdog and laugh at people and ridicule them without even getting paid for it, you’re giving them a free service as well. However, I wouldn’t call people like you *good* advertisement.

    • This reply was modified 1 year, 12 months ago by Nicole6870.

    I am not an advertisement. But if you can not find a secure host in this day that support secure code that is not many years out dated there is something wrong.

    And this is not a matter of your car being old so I won’t fix it. This is getting mad a Toyota for not redesigning their car to fit your old garage.

    Plugin Author nosilver4u

    (@nosilver4u)

    I’m not sure there is any good correlation with a car metaphor here…

    The fact is, using old versions of PHP is dangerous, and it impedes the performance of your site.
    Those are the two most important reasons I have chosen to stop supporting old versions of PHP within EWWW IO. If I get even 10 people to upgrade, it’s worth it. I’ll take all the flak from people who don’t understand the seriousness of the issue, but I hope eventually even they will realize the value of upgrading PHP. I just hope it doesn’t have to be through a PHP security flaw exploited on their site.

    Again: https://docs.ewww.io/article/55-upgrading-php

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    I think the plugin author has made his position clear. Closing the topic.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Deleted it due to lack of common sense’ is closed to new replies.