Support » Plugin: Regenerate Thumbnails » Delete old unregistered sizes does not work

  • Rubidze

    (@rubidze)


    I searched the forum for this issue and see that others had this problem too, but in other topics it was resolved by checking this option in Regenerate Thumbnails window or the topic was marked resolved without giving any deedback.

    My problem is that I certainly select this Delete thumbnail files for old…”, new thumbnail sizes are generated, but old ones are not deleted from server.

    Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Jake Morrison

    (@jakeom)

    Hi there!

    I just tried to reproduce this and wasn’t able to. I even tried manually updating the post meta _wp_attachment_metadata and removed the sizes there to see if it would work with the file search method.

    A few things to check:
    – On the Regenerate Thumbnails page, do you only see the registered sizes (under “Thumbnail Sizes”) you expect to see generated?
    – Have you checked file permissions on these thumbnails?

    Are you finding this is broken for all images or just some?

    Thank you @jakeom for looking into this!

    On the Regenerate Thumbnails page I see only registered sizes. Old sizes are not listed anymore.

    After plugin does it’s work, new sizes are generated as expected, but old sizes remain on the server.

    I don’t think there is a problem with file permissions as I can delete image from media library and then the file is removed from the server.

    Anything else I could check?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.