Support » Plugin: Autoptimize » Delete Notice: Check out the Autoptimize Extra settings to activate this option.

  • Resolved nick8182

    (@nick8182)


    hi, can you tell me how to cancel this notification (Did you know Autoptimize includes on-the-fly image optimization and CDN via ShortPixel? Check out the Autoptimize Extra settings to activate this option.), click on the X symbol, delete it but then on each page, reappear.

    Versione 2.4.1

    • This topic was modified 11 months, 2 weeks ago by  nick8182.
Viewing 15 replies - 1 through 15 (of 87 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    weird, it *should* indeed disappear ..

    the framework used to handle this relies on javascript and an AJAX-request being done and a transient being stored. So if somehow there are JS errors happening (check your browser console) or you have something blocking the AJAX request (check browser network tab) or something deleting transients (or having them cached and thus hiding the actual state or so), then you might indeed see this reappear.

    feel free to follow up on this if you find out what is causing it, if/ where possible I’ll assist and I’ll update for the next version of AO if applicable.

    frank

    thanks for the answer, I do not notice errors, with the previous version the notification disappeared, while with the last update, always reappears.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I re-tested on 2 sites, and there it does disappear as it should Nick, so no idea why it’s not working for you I’m afraid. If you want a quick and somewhat easy solution; edit wp-content/autoptimize/classes/autoptimizeMain.php and on line 550 change

    $_ao_imgopt_active = false;

    into

    $_ao_imgopt_active = true;

    frank

    Have the same problem – can’t dismiss the notice. AJAX gets fired and responds with 200. But on next load – notice is back. I don’t have the time at the moment to enable/disable all plugins I have active but it’s only 7 and all are “well-known” ones.

    If I’d have to bet I’d say the “dismiss_admin_notice” AJAX endpoint name is already registered by some other plugin.

    action: dismiss_admin_notice
    option_name: ao-img-opt-plug
    dismissible_length: 123
    nonce: xxx
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    If I’d have to bet I’d say the “dismiss_admin_notice” AJAX endpoint name is already registered by some other plugin.

    the code of https://github.com/collizo4sky/persist-admin-notices-dismissal/ is written in such a way that it can be reused so this _should_ not happen (unless another plugin uses another solution to dismiss notices that uses the exact same endpoint). I’ll check with the developer of persist-admin-notices-dismissal to see if he has an idea.

    I’ll dig into it on the problematic site as soon as I can and let you know too. Thanks!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    could it be redis/ memcache interfering with the transient being read somehow? do you have a db or object cache and if so can you purge it?

    The site’s on SiteGround so cache is enabled. But should be completely off on /wp-admin/.

    Tried purging – no change 🙁

    Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    You can disable the Memcache if you have it enabled. The Dynamic caching is not active for logged in users at all so it’s not what’s causing issues.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    yes, but that’s the page cache, but does SG also has Memcached, so maybe have a look at cfr. https://www.siteground.com/tutorials/supercacher/memcached/#How_to_flush_Memcached ?

    thanks hristo-sg! 🙂

    • This reply was modified 11 months, 2 weeks ago by  Optimizing Matters. Reason: thanking hristo-sg

    I also use siteground, with cache enabled, the strange thing is that with the previous version of the plugin, the notification once deleted no longer appears, while after the update the notification even if it is deleted, always reappears.

    Tried disabling the cache on the whole acc – no change.

    Same issue here. Unable to dismiss “Did you know Autoptimize includes on-the-fly image optimization and CDN via ShortPixel? Check out the Autoptimize Extra settings to activate this option.”

    I’m a SiteGround user as well. Flushed the cache and no difference.

    I’ve tested on a clean SG install – works. So probably a conflict with another plugin. I’ll do a grep to see if any other plugins I use have the same notifications help lib.

    +1

    We get the same message on all plugin pages and dashboard. Please fix this – pronto!

    Whatever you did with V2.4.1 needs to be reversed. Not a good way to promote a new feature.

    We also use SG, cleared all caches, and the pesky message came back.

    Screenshots:

    http://prntscr.com/l5caum
    http://prntscr.com/l5cc5t
    http://prntscr.com/l5ccj4
    http://prntscr.com/l5cikq

    Thank you!

    PS: Issue also reported here: https://wordpress.org/support/topic/cant-remove-shortpixel-admin-notice/

    • This reply was modified 11 months, 2 weeks ago by  jetxpert.
    • This reply was modified 11 months, 2 weeks ago by  jetxpert.
Viewing 15 replies - 1 through 15 (of 87 total)
  • You must be logged in to reply to this topic.