WordPress.org

Forums

WP Security Audit Log
[resolved] Delete Logs (11 posts)

  1. chuyqwerty
    Member
    Posted 9 months ago #

    I am trying to delete the logs. I change the setting to "Keep up to 10 alerts" but it still shows every single one. I dont want all the alerts. I also changed to delete alerts older than 1 day but it shows all.

    Please help. Thank you so much

    https://wordpress.org/plugins/wp-security-audit-log/

  2. WPWhiteSecurity
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Chuyqwerty,

    Thank you for using our plugin.

    Can you please get in touch with us by sending us an email on plugins@wpwhitesecurity.com so we can tell you how to enable logging and see what might be triggering this behaviour?

    Looking forward to hearing from you.

  3. WPWhiteSecurity
    Member
    Plugin Author

    Posted 7 months ago #

    Hi there,

    This issue has been fixed quite some time ago. Can you please update to the latest version of the plugin?

    Thank you for using our plugin and do not hesitate to get in touch should you have any further queries.

    Have a great day!

  4. siprof
    Member
    Posted 2 months ago #

    Same problem here, set to 10 alerts and even press Run manually did not work. Plugin version 1.3.3, PHP Version: 5.6.4-1~dotdeb.1, MySQL Database Version : 5.6.21-1~dotdeb.1-log

  5. WPWhiteSecurity
    Member
    Plugin Author

    Posted 2 months ago #

    HI Siprof,

    This is a relatively old issue and most probably (for some reason) your settings were not updated properly.

    I would recommend you to do the following:

    1. Disable the plugin
    2. Delete the below options from the WordPress options table (default wp_options)
    3. Enable the plugin
    4. Reconfigure the pruning rules

    Can you please try it out and let us know?

    Thank you.

  6. siprof
    Member
    Posted 2 months ago #

    Hi WPWhiteSecurity,

    What did you mean by: delete the below options?
    Did you mean Drop wp_wsal_metadata & wp_wsal_occurences table?
    I already did and the pruning rules still won't work...

  7. WPWhiteSecurity
    Member
    Plugin Author

    Posted 2 months ago #

    HI Siprof,

    Sorry didn't mention the options in my previous response.

    Those you mentioned are the tables where the WordPress security alerts are stored, hence by deleting those you are deleting all the alerts.

    The plugin options are stored in the wp_options table in the WordPress database. Those related to pruning are mainly the following:

    wsal-pruning-date
    wsal-pruning-limit-e
    wsal-pruning-limit

    The next step is:

    1. Disable the plugin
    2. Access the WordPress database using phpMyAdmin or something similar
    3. Browse through the wp_options table (wp_ is the default prefix, you might have changed it)
    4. Find the below options:

    wsal-pruning-date
    wsal-pruning-limit-e
    wsal-pruning-limit

    5. Delete these options
    6. Activate the plugin
    7. Configure again the pruning options.

    This should work.

    Let me know how it goes or if you have any further queries.

  8. siprof
    Member
    Posted 2 months ago #

    Yep, now it works. Thanks! :)

  9. b-cat
    Member
    Posted 3 weeks ago #

    I followed WPWhiteSecurity's instructions above exactly, and this has not fixed this problem for me. The Audit Log Viewer is still showing hundreds of alerts after I have manually limited alerts to 10 alerts.

    I am using WP Security Audit Log Version 1.4.0, and WordPress version 4.1.1.

    Any suggestions? Do I need to delete the plugin and reinstall it?

  10. b-cat
    Member
    Posted 3 weeks ago #

    Hmm...now it is working properly! Maybe it took some time for the deleted tables to populate on the site server. I have been able to manually delete the alerts now.

    Thanks!

  11. WPWhiteSecurity
    Member
    Plugin Author

    Posted 3 weeks ago #

    Glad your issue is solved. Should you encounter any further problems, or have any queries do not hesitate to get in touch.

    Thank you for using our plugin.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags