Support » Plugin: Delete Me » Delete Account Link not showing

  • Resolved rainer4th

    (@rainer4th)



    Hi there,

    I have installed and activated the plugin. Logged in with role “customer” (Woocommerce). The Delete Account link is not showing. What can I do?

    Thanks,

    Rainer

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author cmc3215

    (@cmc3215)

    Hello Rainer, and thanks for your question.

    I would first try going to the Settings -> Delete Me subpanel, check the WordPress “Customer” role, and click Save Changes.

    Are you trying to use the [plugin_delete_me /] shortcode?

    If so, which Woocommerce page (e.g. My account page) are you trying to use the shortcode on?

    If you’re not using the shortcode, you will not see the link because Woocommerce bypasses the default WordPress profile page.

    You may have a WordPress page set up as your Woocommerce “My account page” which contains the shortcode [woocommerce_my_account /]. If so, you could add the Delete Me shortcode into that page too. However, doing so will add the delete link to every page within the my account area. Not pretty.

    If you would like to use the shortcode to place the delete link at the bottom of your Woocommerce “Account Details” page, then follow these steps. I just tested them with the latest versions of WordPress and Woocommerce.

    Disclaimer: Anyone following these instructions does so at his or her own risk.

    1. Copy the form-edit-account.php file that resides in the wp-content/plugins/woocommerce/templates/myaccount folder.
    2. Navigate to the wp-content/themes folder and open the folder for your current active theme.
    3. Inside your current active theme folder, create a new folder named woocommerce
    4. Then, inside the new woocommerce folder, create another folder named myaccount and paste the previously copied form-edit-account.php file into that folder.
    5. Finally, edit the form-edit-account.php file by placing a new line at the bottom of that file that reads <?php echo do_shortcode( '[plugin_delete_me /]' ); ?>
    6. That’s it! If for some reason it doesn’t show up, try clearing your browser cache.
    • This reply was modified 7 months, 1 week ago by  cmc3215.

    This helped me out. Thank you!

    However, now there is another problem. When the user clicks on the deletion link, the account is deleted without further warning. The JS confirm does not appear, althougn the checkbox “JS Confirm Enabled” in the plugin settings is activated.

    Plugin Author cmc3215

    (@cmc3215)

    Hi Rainer,

    You’re welcome, and thanks for letting me know that progress was made.

    I just quickly created a test account on your website and the JavaScript confirm dialog appeared as expected.

    Google Chrome screenshot of delete prompt on your website…
    https://ibb.co/cOQxMc

    If you are referring to something else, please clarify.

    If you are by chance using translations to change the prompt text, there might be single quotations in the text causing the JavaScript to fail.

    Regards,
    Clint

    Plugin Author cmc3215

    (@cmc3215)

    Hello again Rainer,

    I see now why you are experiencing the issue. You have accidentally included a line break at the end of your confirm message for the DE locale. The EN locale is working fine.

    So, just to be perfectly clear, this was the prompt message in your source code:

    ACHTUNG!\n\nBist du sicher, dass du den Benutzer clint3215 von Thomas Hübl löschen möchtest?

    The invisible line break is after möchtest?.

    So, go to wherever you entered that message, place your cursor between the t and ? and press the Delete key a few times to be sure you erased the line break, then retype the ? at the end.

    Regards,
    Clint

    Hi Clint,

    Thank you very much! Now it works fine.

    Regards,
    Rainer

    answerseeker

    (@answerseeker)

    Sorry- I experience the same issue: even though I followed your steps and copied the .php im the woocommerce folder of my theme the delete option does not show. 🙁 What else can I check? Thanks!

    answerseeker

    (@answerseeker)

    Found the solution myself after reading this: https://wordpress.org/support/topic/cant-display-the-delete-me-link/

    I was not aware of the fact that as an admin I can see everything in a buyer/vendor account EXCEPT your delete option. That’s quite strange but I can live with that fact. Thanks for creating this plugin. It is still not ideal for my purpose but it is a great help for me!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Delete Account Link not showing’ is closed to new replies.