Support » Fixing WordPress » delay/timeout after submitting post?

  • This qualifies as an annoyance more than anything. But on my install, I’ve noticed occasional delays in the edit/post section after finishing a post. The submit/post/blog button just hangs. Interestingly, even though it doesn’t go to a new page, it actually has successfully made the post (I can clearly see it on the View Site option).
    If I hit the button more than once, then I will see multiple versions of the post repeated on the weblog. Anybody seen this?

Viewing 14 replies - 1 through 14 (of 14 total)
  • It’s the pinging. If you aren’t linking to any pingback enabled sites uncheck the pingback option. Eventually I’d like to move the pingy things into a popup window that gives detailed progress. Actually posting an entry takes no time at all.
    It probably wouldn’t hurt either to have some javascript that disables the “Blog This!” button after it’s been pushed.

    Please please do move the pingy things into a popup window that gives detailed progress – I’m getting repeated posts because the submission is timing out and the browser is resending the form.

    Sounds like something that should go into .73 🙂

    How to uncheck the pingback option?

    Wow, that is a really old thread, WebSP, almost 2 years old!

    You can go to options, and turn off the “ping by default” option, or do it on a post by post basis at the write post page by unchecking the option.

    But I am having this problem also 😐

    I am runing version 1.2.2 and I am unnable to fins that “ping by default” option, under “Options”. Does it still exist?

    I mean, it’s not this problem, but it’s simillar. When I click the save when editing a post, I hangs and gives me a blank page.

    OPTIONS > DISCUSSION near the top.

    Resurrecting threads from the old is always good because it proves that the poster actually did a “search” before querying the elite intellectuals whom scour these forums.

    Oh, there it is: “Allow link notifications from other Weblogs (pingbacks and trackbacks.)”

    I had it turned off. Any other ideas?

    I guess you should turn off the one which is above that, i.e.:
    “Attempt to notify any Weblogs linked to from the article (slows down posting.) ”

    That one is turned off also, yet the problems persist. No idea why… 😐

    earlier replies are not appearing–sorry for this if it’s a double post.

    In 1.5.2 I am experience minutes long delays in redrawing the page after submitting a post. The database is being updated immediately, and switching tabs or looking at the raw data in the sql tables proves the update is almost instantaneous. However, redrawing of the (now) empty post page can take minutes.

    Different browsers or OSs make no difference.

    INterestingly, if I create a Page, the screen update is always very fast–yet posts, even when just one or two words, show a delay long enough occasionally to time out the browser.

    Having the same problem even with turning ping off in posts.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘delay/timeout after submitting post?’ is closed to new replies.