WordPress.org

Forums

Jetpack by WordPress.com
[resolved] define('JETPACK_DEV_DEBUG', true); not working? (5 posts)

  1. TJ Kelly
    Member
    Posted 1 year ago #

    I can't seem to enable most Jetpack modules. Here's a screenshot of my modules.

    • I'm working locally using MAMP.
    • I have define('JETPACK_DEV_DEBUG', true); in my wp-config.php file.

    Am I missing something? How can I enable Jetpack comments in local development?

    https://wordpress.org/plugins/jetpack/

  2. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi,

    If you're working locally, you can't use Jetpack comments. The modules that are unavailable to activate are those that require a WordPress.com to function.

  3. TJ Kelly
    Member
    Posted 1 year ago #

    I was under the impression that JETPACK_DEV_DEBUG allowed devs to work w/ jetpack modules offline. Did I misunderstand?

  4. Ryan Cowles
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Howdy TJ! I responded to the email that you sent in, but just wanted to mirror the answer here for anyone else with a similar question.

    Development Mode allows you to work with some Jetpack modules offline, but not all. The modules that require a connection to WordPress.com (like Jetpack Comments) cannot be activated when working locally, since a local site cannot connect to our servers.

    I hope this helps clear things up!

  5. TJ Kelly
    Member
    Posted 1 year ago #

    Thank you. I understand now, but I have to say that I think your documentation is unclear about this. I now understand what you mean by this line from your post announcing dev mode:

    With this, features that do not require a connection to WordPress.com servers can be activated on a localhost WordPress installation for testing.

    It would have helped me and might help others like me if you listed on your site or indicated within the Jetpack admin screen which modules can work offline and which can't. I gather you must have decided that "there's no Activate button" is enough to convey this point. I'd suggest adding something to tell devs WHY there's no Activate button.

    Thanks for responding. I hope my feedback proves useful to you. And thanks for the awesome plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic