Support » Plugin: W3 Total Cache » Define, force a partial renew (example : a plugin) into the cache

  • Resolved Trebly



    The plugin “Max Mega Menu” give the advice, when updates of parameters don’t appear, to “try to purge the W3 cache” for the plugin.

    I don’t want to inactivate or fully purge the whole cache, because often I perform little modifications while the site is running.

    What is the way to force W3cache to renew for a defined plugin.

    note : for the theme or other upgrades I change the version into the declaration of the file.

    Best regards


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Marko Vasiljevic


    Hello @trebly

    Thank you for your inquiry and I am happy to assist you with this.
    Just to make sure I understand your question. It seems that you want to clear and rebuild the cache for the menu and not for the entire page/website.
    If this is the case which parameters are being modified? I.E JS files, images, etc.
    If you don’t mind, could you please reply to clarify if that is the case?



    Hi Trebly & Marko,

    Tom here – the developer of MMM.

    Max Mega Menu generates a CSS file and stores it under wp-content/uploads/maxmegamenu/style.css. This file is updated each time the menu theme is changed. If w3 total cache is caching/minifying/combining that file then the changes won’t show up until the w3 total cache CSS cache has been cleared.


    Plugin Support Marko Vasiljevic


    Hello @megamenu @trebly

    Thank you for clarification.
    If you have enabled Minify on Auto, you can simply exclude that file from being minified.
    Just add wp-content/uploads/maxmegamenu/style.css to “Never minify the following CSS files:” in Performance>Minify, Advanced sub-box.
    I hope this helps!

    Plugin Support Marko Vasiljevic


    Hello @trebly

    Any update on this?

    Plugin Support Marko Vasiljevic


    No activity for a week.
    Marking topic as resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.